summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-11 15:10:34 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-11 15:10:34 +0000
commit02de54fae4829ca926ec798db53a396b83ab1971 (patch)
tree030b26267d21c39bb3fbac2a3ff09b19e2c9c9b4 /dev-db/phpmyadmin
parentDropping to maintainer-needed, not sure why it belonged to hardened (diff)
downloadgentoo-2-02de54fae4829ca926ec798db53a396b83ab1971.tar.gz
gentoo-2-02de54fae4829ca926ec798db53a396b83ab1971.tar.bz2
gentoo-2-02de54fae4829ca926ec798db53a396b83ab1971.zip
Version bump, bug #438804
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.5.3.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index d48d313c2d77..66e142aa60c2 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.474 2012/09/26 20:04:20 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.475 2012/11/11 15:10:34 blueness Exp $
+
+*phpmyadmin-3.5.3 (11 Nov 2012)
+
+ 11 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +phpmyadmin-3.5.3.ebuild:
+ Version bump, bug #438804
26 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org> phpmyadmin-3.5.2.2.ebuild:
ppc/ppc64 stable wrt #432340
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.5.3.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.5.3.ebuild
new file mode 100644
index 000000000000..0c356f3668e0
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-3.5.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.5.3.ebuild,v 1.1 2012/11/11 15:10:34 blueness Exp $
+
+EAPI="4"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc Documentation.txt README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}