summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-19 18:23:41 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-19 18:23:41 +0000
commita77722b169906bf1882b4bb13e79b276db13fc60 (patch)
treeeb115c13d3229a21625cd5ad4b1163fd701ad941 /dev-db/phpmyadmin
parentExplicitly disable documentation. (diff)
downloadgentoo-2-a77722b169906bf1882b4bb13e79b276db13fc60.tar.gz
gentoo-2-a77722b169906bf1882b4bb13e79b276db13fc60.tar.bz2
gentoo-2-a77722b169906bf1882b4bb13e79b276db13fc60.zip
Version bump, bug #444948
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/ChangeLog9
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.5.7.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 54dc16bc2cc1..0a001488091c 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.480 2012/12/01 19:11:02 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.481 2013/02/19 18:23:41 blueness Exp $
+
+*phpmyadmin-3.5.7 (19 Feb 2013)
+
+ 19 Feb 2013; Anthony G. Basile <blueness@gentoo.org> +phpmyadmin-3.5.7.ebuild:
+ Version bump, bug #444948
01 Dec 2012; Raúl Porcel <armin76@gentoo.org> phpmyadmin-3.5.3.ebuild:
alpha/sparc stable wrt #438804
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.5.7.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.5.7.ebuild
new file mode 100644
index 000000000000..0aa0cff285a3
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-3.5.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.5.7.ebuild,v 1.1 2013/02/19 18:23:41 blueness Exp $
+
+EAPI="4"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc Documentation.txt README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}