summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-04-09 23:50:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-04-09 23:50:00 +0000
commitc36a20a616a03d5ef18bdeee4f397b0a5c897851 (patch)
tree3613a9d01b8f44064db1066416d7a06f70332558 /dev-db/phpmyadmin
parentAdd newline. (diff)
downloadgentoo-2-c36a20a616a03d5ef18bdeee4f397b0a5c897851.tar.gz
gentoo-2-c36a20a616a03d5ef18bdeee4f397b0a5c897851.tar.bz2
gentoo-2-c36a20a616a03d5ef18bdeee4f397b0a5c897851.zip
Version bump, ready for MySQL conference.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.5.0.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 7361649c56c5..46a4e115f51e 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.465 2012/01/01 15:15:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.466 2012/04/09 23:50:00 robbat2 Exp $
+
+*phpmyadmin-3.5.0 (09 Apr 2012)
+
+ 09 Apr 2012; Robin H. Johnson <robbat2@gentoo.org> +phpmyadmin-3.5.0.ebuild:
+ Version bump, ready for MySQL conference.
01 Jan 2012; Raúl Porcel <armin76@gentoo.org> phpmyadmin-3.4.9.ebuild:
alpha/sparc/x86 stable wrt #395715
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.5.0.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.5.0.ebuild
new file mode 100644
index 000000000000..e928f3fc3f43
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-3.5.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.5.0.ebuild,v 1.1 2012/04/09 23:50:00 robbat2 Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ <dev-lang/php-5.3[spl,pcre]
+ >=dev-lang/php-5.3
+ )
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc Documentation.txt README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}