summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-07-14 18:40:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-07-14 18:40:22 +0000
commit3e9cfb0754b1ff3ce6eab41a76d49210edd45f6b (patch)
treee67103bd9272f2c2e1873df6a225fc3926771e62 /dev-db/postgresql-base
parentVersion bump. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-3e9cfb0754b1ff3ce6eab41a76d49210edd45f6b.tar.gz
gentoo-2-3e9cfb0754b1ff3ce6eab41a76d49210edd45f6b.tar.bz2
gentoo-2-3e9cfb0754b1ff3ce6eab41a76d49210edd45f6b.zip
Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/postgresql-base')
-rw-r--r--dev-db/postgresql-base/ChangeLog9
-rw-r--r--dev-db/postgresql-base/files/postgresql-9.0-base.3.patch147
-rw-r--r--dev-db/postgresql-base/files/postgresql-9.0-common.3.patch14
-rw-r--r--dev-db/postgresql-base/postgresql-base-9.0_beta3.ebuild161
4 files changed, 330 insertions, 1 deletions
diff --git a/dev-db/postgresql-base/ChangeLog b/dev-db/postgresql-base/ChangeLog
index 88b2b4a517d7..f26c7c62d45b 100644
--- a/dev-db/postgresql-base/ChangeLog
+++ b/dev-db/postgresql-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/postgresql-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.65 2010/07/13 14:21:28 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.66 2010/07/14 18:40:22 patrick Exp $
+
+*postgresql-base-9.0_beta3 (14 Jul 2010)
+
+ 14 Jul 2010; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-base-9.0_beta3.ebuild, +files/postgresql-9.0-base.3.patch,
+ +files/postgresql-9.0-common.3.patch:
+ Bump
13 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
postgresql-base-8.4.4-r2.ebuild:
diff --git a/dev-db/postgresql-base/files/postgresql-9.0-base.3.patch b/dev-db/postgresql-base/files/postgresql-9.0-base.3.patch
new file mode 100644
index 000000000000..ba6a92688bb8
--- /dev/null
+++ b/dev-db/postgresql-base/files/postgresql-9.0-base.3.patch
@@ -0,0 +1,147 @@
+diff -Naur postgresql-9.0beta3.orig/contrib/Makefile postgresql-9.0beta3/contrib/Makefile
+--- postgresql-9.0beta3.orig/contrib/Makefile 2010-06-14 12:17:56.000000000 -0400
++++ postgresql-9.0beta3/contrib/Makefile 2010-07-11 23:41:57.680531730 -0400
+@@ -5,51 +5,14 @@
+ include $(top_builddir)/src/Makefile.global
+
+ SUBDIRS = \
+- adminpack \
+- auto_explain \
+- btree_gin \
+- btree_gist \
+- chkpass \
+- citext \
+- cube \
+- dblink \
+- dict_int \
+- dict_xsyn \
+- earthdistance \
+- fuzzystrmatch \
+- hstore \
+- intagg \
+- intarray \
+- isn \
+- lo \
+- ltree \
+ oid2name \
+- pageinspect \
+ passwordcheck \
+- pg_archivecleanup \
+- pg_buffercache \
+- pg_freespacemap \
+- pg_standby \
+- pg_stat_statements \
+- pg_trgm \
+ pg_upgrade \
+ pg_upgrade_support \
+ pgbench \
+- pgcrypto \
+- pgrowlocks \
+- pgstattuple \
+- seg \
+- spi \
+- tablefunc \
+- test_parser \
+- tsearch2 \
+ unaccent \
+ vacuumlo
+
+-ifeq ($(with_openssl),yes)
+-SUBDIRS += sslinfo
+-endif
+-
+ ifeq ($(with_ossp_uuid),yes)
+ SUBDIRS += uuid-ossp
+ endif
+diff -Naur postgresql-9.0beta3.orig/src/backend/Makefile postgresql-9.0beta3/src/backend/Makefile
+--- postgresql-9.0beta3.orig/src/backend/Makefile 2010-07-05 14:54:37.000000000 -0400
++++ postgresql-9.0beta3/src/backend/Makefile 2010-07-11 23:46:58.347527452 -0400
+@@ -45,7 +45,7 @@
+
+ ##########################################################################
+
+-all: submake-libpgport submake-schemapg postgres $(POSTGRES_IMP)
++all: someheaders
+
+ ifneq ($(PORTNAME), cygwin)
+ ifneq ($(PORTNAME), win32)
+@@ -114,7 +114,7 @@
+ endif # aix
+
+ # Update the commonly used headers before building the subdirectories
+-$(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/catalog/schemapg.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
++someheaders $(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
+
+ # run this unconditionally to avoid needing to know its dependencies here:
+ submake-schemapg:
+@@ -191,23 +191,7 @@
+
+ ##########################################################################
+
+-install: all installdirs install-bin
+-ifeq ($(PORTNAME), cygwin)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+-endif
+-endif
+-ifeq ($(PORTNAME), win32)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+-endif
+-endif
+- $(MAKE) -C catalog install-data
+- $(MAKE) -C tsearch install-data
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample '$(DESTDIR)$(datadir)/recovery.conf.sample'
++install:
+
+ install-bin: postgres $(POSTGRES_IMP) installdirs
+ $(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
+diff -Naur postgresql-9.0beta3.orig/src/bin/Makefile postgresql-9.0beta3/src/bin/Makefile
+--- postgresql-9.0beta3.orig/src/bin/Makefile 2010-01-02 11:57:58.000000000 -0500
++++ postgresql-9.0beta3/src/bin/Makefile 2010-07-11 23:50:10.762585482 -0400
+@@ -13,8 +13,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-SUBDIRS = initdb pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog
++SUBDIRS = pg_dump psql scripts pg_config
+ ifeq ($(PORTNAME), win32)
+ SUBDIRS+=pgevent
+ endif
+diff -Naur postgresql-9.0beta3.orig/src/include/pg_config_manual.h postgresql-9.0beta3/src/include/pg_config_manual.h
+--- postgresql-9.0beta3.orig/src/include/pg_config_manual.h 2010-01-06 23:53:35.000000000 -0500
++++ postgresql-9.0beta3/src/include/pg_config_manual.h 2010-07-11 23:51:39.925527262 -0400
+@@ -141,7 +141,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+diff -Naur postgresql-9.0beta3.orig/src/Makefile postgresql-9.0beta3/src/Makefile
+--- postgresql-9.0beta3.orig/src/Makefile 2010-01-20 04:16:23.000000000 -0500
++++ postgresql-9.0beta3/src/Makefile 2010-07-11 23:53:43.768528995 -0400
+@@ -15,17 +15,12 @@
+
+ all install installdirs uninstall distprep:
+ $(MAKE) -C port $@
+- $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+- $(MAKE) -C backend/utils/mb/conversion_procs $@
+- $(MAKE) -C backend/snowball $@
+ $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C backend/replication/libpqwalreceiver $@
+ $(MAKE) -C bin $@
+- $(MAKE) -C pl $@
+ $(MAKE) -C makefiles $@
+- $(MAKE) -C test/regress $@
+
+ install: install-local
+
diff --git a/dev-db/postgresql-base/files/postgresql-9.0-common.3.patch b/dev-db/postgresql-base/files/postgresql-9.0-common.3.patch
new file mode 100644
index 000000000000..ab47b0cb9707
--- /dev/null
+++ b/dev-db/postgresql-base/files/postgresql-9.0-common.3.patch
@@ -0,0 +1,14 @@
+diff -Naur postgresql-9.0beta3.orig/configure.in postgresql-9.0beta3/configure.in
+--- postgresql-9.0beta3.orig/configure.in 2010-07-08 22:43:12.000000000 -0400
++++ postgresql-9.0beta3/configure.in 2010-07-12 00:13:37.585527031 -0400
+@@ -19,10 +19,6 @@
+
+ AC_INIT([PostgreSQL], [9.0beta3], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2010, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
diff --git a/dev-db/postgresql-base/postgresql-base-9.0_beta3.ebuild b/dev-db/postgresql-base/postgresql-base-9.0_beta3.ebuild
new file mode 100644
index 000000000000..6e2a8057a37b
--- /dev/null
+++ b/dev-db/postgresql-base/postgresql-base-9.0_beta3.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-9.0_beta3.ebuild,v 1.1 2010/07/14 18:40:22 patrick Exp $
+
+EAPI="2"
+
+WANT_AUTOMAKE="none"
+
+inherit eutils multilib versionator autotools
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+DESCRIPTION="PostgreSQL libraries and clients"
+HOMEPAGE="http://www.postgresql.org/"
+
+MY_PV=${PV/_/}
+SRC_URI="mirror://postgresql/source/v${MY_PV}/postgresql-${MY_PV}.tar.bz2"
+S=${WORKDIR}/postgresql-${MY_PV}
+
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+ linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
+ linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
+ linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
+ linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="doc kerberos nls pam readline ssl threads zlib ldap pg_legacytimestamp ${IUSE_LINGUAS}"
+RESTRICT="test"
+
+wanted_languages() {
+ for u in ${IUSE_LINGUAS} ; do
+ use $u && echo -n "${u#linguas_} "
+ done
+}
+
+RDEPEND="kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ readline? ( >=sys-libs/readline-4.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ >=app-admin/eselect-postgresql-0.3
+ virtual/libintl
+ !!dev-db/postgresql-libs
+ !!dev-db/postgresql-client
+ !!dev-db/libpq
+ !!dev-db/postgresql
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-devel/bison-1.875
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( ~dev-db/postgresql-docs-${PV} )"
+
+src_prepare() {
+ epatch "${FILESDIR}/postgresql-9.0-common.3.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-base.3.patch"
+
+ if use kerberos && has_version "<app-crypt/heimdal-1.3.2-r1" ; then
+ epatch "${FILESDIR}/postgresql-base-8.4-9.0-heimdal_strlcpy.patch"
+ fi
+
+ # to avoid collision - it only should be installed by server
+ rm "${S}/src/backend/nls.mk"
+
+ # because psql/help.c includes the file
+ ln -s "${S}/src/include/libpq/pqsignal.h" "${S}/src/bin/psql/"
+ cd "${S}"
+ eautoconf
+}
+
+src_configure() {
+ export LDFLAGS_SL="${LDFLAGS}"
+ econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
+ --datadir=/usr/share/postgresql-${SLOT} \
+ --docdir=/usr/share/doc/postgresql-${SLOT} \
+ --sysconfdir=/etc/postgresql-${SLOT} \
+ --includedir=/usr/include/postgresql-${SLOT} \
+ --mandir=/usr/share/postgresql-${SLOT}/man \
+ --enable-depend \
+ --without-tcl \
+ --without-perl \
+ --without-python \
+ $(use_with readline) \
+ $(use_with kerberos krb5) \
+ $(use_with kerberos gssapi) \
+ "$(use_enable nls nls "$(wanted_languages)")" \
+ $(use_with pam) \
+ $(use_enable !pg_legacytimestamp integer-datetimes ) \
+ $(use_with ssl openssl) \
+ $(use_enable threads thread-safety) \
+ $(use_with zlib) \
+ $(use_with ldap) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ cd "${S}/contrib"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/include/postgresql-${SLOT}/postmaster
+ doins "${S}"/src/include/postmaster/*.h
+ dodir /usr/share/postgresql-${SLOT}/man/man1
+ tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1
+
+ rm -r "${D}/usr/share/doc/postgresql-${SLOT}/html"
+ rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1
+ dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+ cd "${S}/contrib"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+
+ IDIR="/usr/include/postgresql-${SLOT}"
+ cat > "${D}/etc/eselect/postgresql/slots/${SLOT}/base" <<-__EOF__
+postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+postgres_prefix=/usr/$(get_libdir)/postgresql-${SLOT}
+postgres_datadir=/usr/share/postgresql-${SLOT}
+postgres_bindir=/usr/$(get_libdir)/postgresql-${SLOT}/bin
+postgres_symlinks=(
+ ${IDIR} /usr/include/postgresql
+ ${IDIR}/libpq-fe.h /usr/include/libpq-fe.h
+ ${IDIR}/pg_config_manual.h /usr/include/pg_config_manual.h
+ ${IDIR}/libpq /usr/include/libpq
+ ${IDIR}/postgres_ext.h /usr/include/postgres_ext.h
+)
+__EOF__
+
+ cat >"${T}/50postgresql-94-${SLOT}" <<-__EOF__
+ LDPATH=/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
+ MANPATH=/usr/share/postgresql-${SLOT}/man
+ __EOF__
+ doenvd "${T}/50postgresql-94-${SLOT}"
+
+ keepdir /etc/postgresql-${SLOT}
+}
+
+pkg_postinst() {
+ eselect postgresql update
+ [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+ elog "If you need a global psqlrc-file, you can place it in:"
+ elog " '${ROOT}/etc/postgresql-${SLOT}/'"
+ elog
+ elog "The PostgreSQL community has called for more testers of the upcoming 9.0"
+ elog "release. This beta version of the PostgreSQL client applications and libraries,"
+ elog "while moved to ~arch, will never be marked stable. As such, you may not want to"
+ elog "use this package in an environment where incompatible changes are"
+ elog "unacceptable. Bear in mind, though, that these packages are slotted and that you"
+ elog "may have multiple installations simultaneously without conflict. However, you"
+ elog "may only use one set of client applications and libraries via 'eselect'."
+}
+
+pkg_postrm() {
+ eselect postgresql update
+}