summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-09-15 19:53:14 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-09-15 19:53:14 +0000
commit38b47c87f7efee3237c871c7474ef9b818899038 (patch)
tree07016c049fe5de385ea292cb8a50136b1740d20f /dev-db/postgresql
parentFixed dependency to require libid3tag. Closes bug #63158. (Manifest recommit) (diff)
downloadgentoo-2-38b47c87f7efee3237c871c7474ef9b818899038.tar.gz
gentoo-2-38b47c87f7efee3237c871c7474ef9b818899038.tar.bz2
gentoo-2-38b47c87f7efee3237c871c7474ef9b818899038.zip
Added patch not to use termcap library. See bug 63073 and 63181.
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/ChangeLog8
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.4.5-r14
-rw-r--r--dev-db/postgresql/files/postgresql-7.4.5-r1-gentoo.patch28
-rw-r--r--dev-db/postgresql/postgresql-7.4.5-r1.ebuild294
4 files changed, 333 insertions, 1 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 0525fa13f5a5..93a0af396ae1 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.127 2004/09/09 17:36:39 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.128 2004/09/15 19:53:14 nakano Exp $
+
+*postgresql-7.4.5-r1 (15 Sep 2004)
+
+ 15 Sep 2004; Masatomo Nakano <nakano@gentoo.org>
+ +files/postgresql-7.4.5-r1-gentoo.patch, +postgresql-7.4.5-r1.ebuild:
+ Added patch not to use termcap library. See bug 63073 and 63181.
09 Sep 2004; Guy Martin <gmsoft@gentoo.org> postgresql-7.4.5.ebuild:
Stable on hppa.
diff --git a/dev-db/postgresql/files/digest-postgresql-7.4.5-r1 b/dev-db/postgresql/files/digest-postgresql-7.4.5-r1
new file mode 100644
index 000000000000..d41123b52cb6
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.4.5-r1
@@ -0,0 +1,4 @@
+MD5 bffc3fe775c885489f9071e97f43ab9b postgresql-base-7.4.5.tar.bz2 6530104
+MD5 8be416baeeb32518f2b17a91c4caafba postgresql-opt-7.4.5.tar.bz2 332174
+MD5 548a73c898e65f901dbc06d622a2bc63 postgresql-docs-7.4.5.tar.bz2 2409931
+MD5 16d037213b879963724da7809a0a1589 hier-Pg7.4-0.5.3.tar.gz 34662
diff --git a/dev-db/postgresql/files/postgresql-7.4.5-r1-gentoo.patch b/dev-db/postgresql/files/postgresql-7.4.5-r1-gentoo.patch
new file mode 100644
index 000000000000..f07124e905c3
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-7.4.5-r1-gentoo.patch
@@ -0,0 +1,28 @@
+diff -Naru postgresql-7.4.5.org/configure postgresql-7.4.5/configure
+--- postgresql-7.4.5.org/configure 2004-08-18 04:11:24.000000000 +0100
++++ postgresql-7.4.5/configure 2004-09-15 20:28:46.933631781 +0100
+@@ -6003,7 +6003,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ pgac_cv_check_readline=no
+-for pgac_lib in "" " -ltermcap" " -lncurses" " -lcurses" ; do
++for pgac_lib in "" " -lncurses" " -lcurses" ; do
+ for pgac_rllib in -lreadline -ledit ; do
+ pgac_save_LIBS=$LIBS
+ LIBS="${pgac_rllib}${pgac_lib} $LIBS"
+diff -Naru postgresql-7.4.5.org/src/bin/initdb/initdb.sh postgresql-7.4.5/src/bin/initdb/initdb.sh
+--- postgresql-7.4.5.org/src/bin/initdb/initdb.sh 2004-05-05 17:09:56.000000000 +0100
++++ postgresql-7.4.5/src/bin/initdb/initdb.sh 2004-09-15 20:28:35.507026977 +0100
+@@ -1145,11 +1145,7 @@
+ echo
+ echo "Success. You can now start the database server using:"
+ echo ""
+-echo " $PGPATH/postmaster -D $PGDATA"
+-echo "or"
+-# (Advertise -l option here, otherwise we have a background
+-# process writing to the terminal.)
+-echo " $PGPATH/pg_ctl -D $PGDATA -l logfile start"
++echo " /etc/init.d/postgresql start"
+ echo
+
+ exit 0
diff --git a/dev-db/postgresql/postgresql-7.4.5-r1.ebuild b/dev-db/postgresql/postgresql-7.4.5-r1.ebuild
new file mode 100644
index 000000000000..a874c934a5ba
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.4.5-r1.ebuild
@@ -0,0 +1,294 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.5-r1.ebuild,v 1.1 2004/09/15 19:53:14 nakano Exp $
+
+inherit eutils gnuconfig flag-o-matic
+
+DESCRIPTION="sophisticated Object-Relational DBMS."
+HOMEPAGE="http://www.postgresql.org/"
+P_HIERPG="hier-Pg7.4-0.5.3"
+SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
+ mirror://postgresql/source/v${PV}/${PN}-opt-${PV}.tar.bz2
+ doc? ( mirror://postgresql/source/v${PV}/${PN}-docs-${PV}.tar.bz2 )
+ pg-hier? ( ftp://gborg.postgresql.org/pub/hierpg/stable/${P_HIERPG}.tar.gz )"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
+IUSE="ssl nls java python tcltk perl libg++ pam readline zlib doc pg-hier pg-vacuumdelay pg-intdatetime"
+
+DEPEND="virtual/libc
+ sys-devel/autoconf
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/bison-1.875
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+ java? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
+ dev-java/java-config )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+# java dep workaround for portage bug
+# x86? ( java? ( =dev-java/sun-jdk-1.3* >=dev-java/ant-1.3 ) )
+RDEPEND="virtual/libc
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3* )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+PG_DIR="/var/lib/postgresql"
+MAX_CONNECTIONS=1024
+
+pkg_setup() {
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 4 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ fi
+ fi
+}
+
+check_java_config() {
+ JDKHOME="`java-config --jdk-home`"
+ if [[ -z "${JDKHOME}" || ! -d "${JDKHOME}" ]]; then
+ NOJDKERROR="You need to use java-config to set your JVM to a JDK!"
+ eerror "${NOJDKERROR}"
+ die "${NOJDKERROR}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A} || die
+ epatch ${FILESDIR}/${P}-${PR}-gentoo.patch
+ if use pg-hier; then
+ cd ${S} || die
+ epatch ${WORKDIR}/${P_HIERPG}.diff
+ fi
+
+ if use pg-vacuumdelay; then
+ cd ${S} || die
+ epatch ${FILESDIR}/${P}-vacuum-delay.patch
+ fi
+
+ if [ "${ARCH}" = "hppa" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/${P}-hppa-testandset.patch
+ fi
+}
+
+src_compile() {
+ filter-flags -ffast-math
+
+ if use java; then
+ check_java_config
+ fi
+
+ local myconf
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="$myconf --with-python"
+ use perl && myconf="$myconf --with-perl"
+ use java && myconf="$myconf --with-java"
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-nls"
+ use libg++ && myconf="$myconf --with-CXX"
+ use pam && myconf="$myconf --with-pam"
+ use readline || myconf="$myconf --without-readline"
+ use zlib || myconf="$myconf --without-zlib"
+ use pg-intdatetime && myconf="$myconf --enable-integer-datetimes"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ # Detect mips systems properly
+ gnuconfig_update
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${PF} \
+ --libdir=/usr/lib \
+ --includedir=/usr/include/postgresql/pgsql \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-maxbackends=${MAX_CONNECTIONS} \
+ $myconf || die
+
+ make || die
+ cd contrib
+ make || die
+}
+
+src_install() {
+ if use perl; then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} includedir_server=/usr/include/postgresql/server includedir_internal=/usr/include/postgresql/internal LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} includedir_server=/usr/include/postgresql/server includedir_internal=/usr/include/postgresql/internal install-all-headers || die
+ cd ${S}/contrib
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}
+ if use pg-hier; then
+ dodoc ${WORKDIR}/README-${P_HIERPG}.html || die
+ fi
+ dodoc README HISTORY COPYRIGHT INSTALL
+ dodoc contrib/adddepend/*
+
+ exeinto /usr/bin
+
+ if use java; then
+ # we need to remove jar file after dojar; otherwise two same jar
+ # file are installed.
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar || die
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+ dojar ${D}/usr/share/postgresql/java/postgresql-examples.jar || die
+ rm ${D}/usr/share/postgresql/java/postgresql-examples.jar
+ fi
+
+ # backward compatibility
+ for i in ${D}/usr/include/postgresql/pgsql/*
+ do
+ ln -s ${i} ${D}/usr/include/
+ done
+
+ cd ${S}/doc
+ dodoc FAQ* README.* TODO bug.template
+ if use doc; then
+ cd ${S}/doc
+ docinto FAQ_html || die
+ dodoc src/FAQ/* || die
+ docinto sgml || die
+ dodoc src/sgml/*.{sgml,dsl} || die
+ docinto sgml/ref || die
+ dodoc src/sgml/ref/*.sgml || die
+ docinto TODO.detail || die
+ dodoc TODO.detail/* || die
+ fi
+
+ cd ${S}
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/postgresql.init-${PV} postgresql || die
+ newexe ${FILESDIR}/pg_autovacuum.init-${PV} pg_autovacuum || die
+ dosed "s:___DOCDIR___:/usr/share/doc/${PF}:" /etc/init.d/pg_autovacuum
+
+ insinto /etc/conf.d/
+ newins ${FILESDIR}/postgresql.conf-${PV} postgresql || die
+ newins ${FILESDIR}/pg_autovacuum.conf-${PV} pg_autovacuum || die
+}
+
+pkg_postinst() {
+ einfo "Make sure the postgres user in /etc/passwd has an account setup with /bin/bash as the shell"
+
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -eq 4 ] ; then
+ ewarn ""
+ ewarn "If you are upgrading from PostgreSQL 7.4 or 7.4.1, it is strongly recommended"
+ ewarn "that you read the release notes concerning changes to the system catalogs."
+ ewarn "You can run 7.4.2 without rerunning initdb, however you may still experience"
+ ewarn "random crashes due to an error in pg_statistic."
+ ewarn ""
+ ewarn "If you prefer not to re-initdb your installation, the release notes contain"
+ ewarn "a procedure for manually correcting the problem."
+ ewarn ""
+ fi
+
+ if use pg-hier; then
+ ewarn ""
+ ewarn "REQUIRED!! After installing patched PostgreSQL by pg-hier"
+ ewarn "it is required to run 'initdb'. Without this Pg will fail "
+ ewarn "with error "
+ ewarn "ERROR: did not find '}' at end of input node. "
+ ewarn ""
+ fi
+ else
+ einfo ""
+ einfo "Execute the following command"
+ einfo "ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config"
+ einfo "to setup the initial database environment."
+ einfo ""
+ fi
+
+ einfo ""
+ einfo "Python modules was removed from PostgreSQL package."
+ einfo "If you need it, please run \"emerge dev-db/pygresq\"."
+ einfo ""
+}
+
+pkg_config() {
+ einfo "Creating the data directory ..."
+ mkdir -p ${PG_DIR}/data
+ chown -Rf postgres:postgres ${PG_DIR}
+ chmod 700 ${PG_DIR}/data
+
+ einfo "Initializing the database ..."
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ else
+ einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
+ einfo "Read the documentation to check how to upgrade to version ${PV}."
+ fi
+ else
+ local SEM=`sysctl -n kernel.sem | cut -f-3`
+ local SEMMNI=`sysctl -n kernel.sem | cut -f4`
+ local SEMMNI_MIN=`expr \( ${MAX_CONNECTIONS} + 15 \) / 16`
+ local SHMMAX=`sysctl -n kernel.shmmax`
+ local SHMMAX_MIN=`expr 250000 + 30600 \* ${MAX_CONNECTIONS}`
+
+ if [ ${SEMMNI} -lt ${SEMMNI_MIN} ]; then
+ eerror "The current value of SEMMNI is too low"
+ eerror "for postgresql to run ${MAX_CONNECTIONS} connections"
+ eerror "Temporary setting this value to ${SEMMNI_MIN} while creating the initial database."
+ echo ${SEM} ${SEMMNI_MIN} > /proc/sys/kernel/sem
+ fi
+ su postgres -c "/usr/bin/initdb --pgdata ${PG_DIR}/data"
+
+ if [ ! `sysctl -n kernel.sem | cut -f4` -eq ${SEMMNI} ] ; then
+ echo ${SEM} ${SEMMNI} > /proc/sys/kernel/sem
+ ewarn "Restoring the SEMMNI value to the previous value"
+ ewarn "Please edit the last value of kernel.sem in /etc/sysctl.conf"
+ ewarn "and set it to at least ${SEMMNI_MIN}"
+ ewarn ""
+ ewarn " kernel.sem = ${SEM} ${SEMMNI_MIN}"
+ ewarn ""
+ fi
+
+ if [ ${SHMMAX} -lt ${SHMMAX_MIN} ]; then
+ eerror "The current value of SHMMAX is too low for postgresql to run."
+ eerror "Please edit /etc/sysctl.conf and set this value to at least ${SHMMAX_MIN}."
+ eerror ""
+ eerror " kernel.shmmax = ${SHMMAX_MIN}"
+ eerror ""
+
+ fi
+
+ einfo "If you are upgrading from a pre-7.3 version of PostgreSQL, please read"
+ einfo "the README.adddepend file for information on how to properly migrate"
+ einfo "all serial columns, unique keys and foreign keys to this version."
+ fi
+}