summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-02 03:36:52 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-02 03:36:52 +0000
commited8c2ad7a1d7820da38b7b72a5dce26d86cfa631 (patch)
tree5b56021ed915d62bea76b8bcfd25ec06baa59d0d /dev-db/recutils
parentvanilla-3.6.5 + genpatches-3.6-4 + grsecurity-2.9.1-3.6.5-201210312121 (diff)
downloadgentoo-2-ed8c2ad7a1d7820da38b7b72a5dce26d86cfa631.tar.gz
gentoo-2-ed8c2ad7a1d7820da38b7b72a5dce26d86cfa631.tar.bz2
gentoo-2-ed8c2ad7a1d7820da38b7b72a5dce26d86cfa631.zip
Fix build with glibc-2.16 (bug #426922).
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-db/recutils')
-rw-r--r--dev-db/recutils/ChangeLog6
-rw-r--r--dev-db/recutils/files/recutils-1.5-glibc-2.16.patch29
-rw-r--r--dev-db/recutils/recutils-1.5.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-db/recutils/ChangeLog b/dev-db/recutils/ChangeLog
index b51b2b8f21cf..f09d8f152871 100644
--- a/dev-db/recutils/ChangeLog
+++ b/dev-db/recutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/recutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/ChangeLog,v 1.2 2012/05/03 02:33:10 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/ChangeLog,v 1.3 2012/11/02 03:36:52 radhermit Exp $
+
+ 02 Nov 2012; Tim Harder <radhermit@gentoo.org> recutils-1.5.ebuild,
+ +files/recutils-1.5-glibc-2.16.patch:
+ Fix build with glibc-2.16 (bug #426922).
03 May 2012; Jeff Horelick <jdhore@gentoo.org> recutils-1.5.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-db/recutils/files/recutils-1.5-glibc-2.16.patch b/dev-db/recutils/files/recutils-1.5-glibc-2.16.patch
new file mode 100644
index 000000000000..8b4997f099de
--- /dev/null
+++ b/dev-db/recutils/files/recutils-1.5-glibc-2.16.patch
@@ -0,0 +1,29 @@
+--- recutils-1.5/lib/stdio.in.h
++++ recutils-1.5/lib/stdio.in.h
+@@ -699,22 +699,11 @@
+ # endif
+ #endif
+
+-#if @GNULIB_GETS@
+-# if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
+-# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-# undef gets
+-# define gets rpl_gets
+-# endif
+-_GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
+-_GL_CXXALIAS_RPL (gets, char *, (char *s));
+-# else
+-_GL_CXXALIAS_SYS (gets, char *, (char *s));
+-# undef gets
+-# endif
+-_GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning. Assume it is
+- always declared, since it is required by C89. */
++ so any use of gets warrants an unconditional warning; besides, C11
++ removed it. */
++#undef gets
++#if HAVE_RAW_DECL_GETS
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
+
diff --git a/dev-db/recutils/recutils-1.5.ebuild b/dev-db/recutils/recutils-1.5.ebuild
index 8216f7361ff4..91bc2fc6c05a 100644
--- a/dev-db/recutils/recutils-1.5.ebuild
+++ b/dev-db/recutils/recutils-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/recutils-1.5.ebuild,v 1.2 2012/05/03 02:33:10 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/recutils-1.5.ebuild,v 1.3 2012/11/02 03:36:52 radhermit Exp $
EAPI=4
@@ -38,6 +38,7 @@ SITEFILE="50${PN}-gentoo.el"
src_prepare() {
epatch "${FILESDIR}"/${P}-automagic.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.16.patch
# Don't unconditionally install emacs files
sed -i -e "/^dist_lisp_DATA/d" etc/Makefile.am || die