summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2007-03-07 23:25:12 +0000
committerMasatomo Nakano <nakano@gentoo.org>2007-03-07 23:25:12 +0000
commit0bc91ec228120e3a43ecd5b2378c5eaad7a22bb8 (patch)
treea7429c2e3a6f2d0d2765b69359341b2ca68ba81b /dev-db/slony1
parentversion bump (diff)
downloadgentoo-2-0bc91ec228120e3a43ecd5b2378c5eaad7a22bb8.tar.gz
gentoo-2-0bc91ec228120e3a43ecd5b2378c5eaad7a22bb8.tar.bz2
gentoo-2-0bc91ec228120e3a43ecd5b2378c5eaad7a22bb8.zip
Version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/ChangeLog7
-rw-r--r--dev-db/slony1/slony1-1.2.6.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index df04f57c7760..ab277149d2df 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/slony1
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.9 2007/02/22 01:09:42 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.10 2007/03/07 23:25:12 nakano Exp $
+
+*slony1-1.2.6 (07 Mar 2007)
+
+ 07 Mar 2007; Masatomo Nakano <nakano@gentoo.org> +slony1-1.2.6.ebuild:
+ Version bump.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-db/slony1/slony1-1.2.6.ebuild b/dev-db/slony1/slony1-1.2.6.ebuild
new file mode 100644
index 000000000000..8901ddbe105d
--- /dev/null
+++ b/dev-db/slony1/slony1-1.2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-1.2.6.ebuild,v 1.1 2007/03/07 23:25:12 nakano Exp $
+
+inherit eutils
+
+IUSE="perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://pgfoundry.org/frs/download.php/1215/${P}.tar.bz2"
+
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-db/postgresql
+ perl? ( dev-perl/DBD-Pg )"
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+
+ econf ${myconf} || die
+ emake || die
+
+ if use perl ; then
+ cd ${S}/tools
+ emake || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+
+ newinitd ${FILESDIR}/slony1.init slony1 || die
+ newconfd ${FILESDIR}/slony1.conf slony1 || die
+
+}