summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-19 00:08:53 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-19 00:08:53 +0000
commit33bc5229c9bab8f089f82c4c4702998b6aa14a7a (patch)
tree76634b349b0146c3c57c62ebf84e996e0cd398b2 /dev-db/tora
parentShould fix java compile bug with pdflib (diff)
downloadgentoo-2-33bc5229c9bab8f089f82c4c4702998b6aa14a7a.tar.gz
gentoo-2-33bc5229c9bab8f089f82c4c4702998b6aa14a7a.tar.bz2
gentoo-2-33bc5229c9bab8f089f82c4c4702998b6aa14a7a.zip
New version. Submitted by Don Seiler
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog10
-rw-r--r--dev-db/tora/files/digest-tora-1.3.71
-rw-r--r--dev-db/tora/tora-1.3.7.ebuild44
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index e77115b29158..b6319c646c94 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for dev-db/tora
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.1 2002/08/06 08:04:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.2 2002/08/19 00:08:53 rphillips Exp $
-*unixODBC-2.0.6 (6 Aug 2002)
+*tora-1.3.7 (18 Aug 2002)
+
+ 18 Aug 2002; Ryan Phillips <rphillips@gentoo.org> :
+
+ New version
+
+*tora-1.3.6.1 (6 Aug 2002)
6 Aug 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
diff --git a/dev-db/tora/files/digest-tora-1.3.7 b/dev-db/tora/files/digest-tora-1.3.7
new file mode 100644
index 000000000000..6c8d076c22be
--- /dev/null
+++ b/dev-db/tora/files/digest-tora-1.3.7
@@ -0,0 +1 @@
+MD5 e3fc2a30748ba36c45f8776f42728f68 tora-alpha-1.3.7.tar.gz 2322826
diff --git a/dev-db/tora/tora-1.3.7.ebuild b/dev-db/tora/tora-1.3.7.ebuild
new file mode 100644
index 000000000000..391ee4218aa4
--- /dev/null
+++ b/dev-db/tora/tora-1.3.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.7.ebuild,v 1.1 2002/08/19 00:08:53 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TOra - Toolkit For Oracle"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+HOMEPAGE="http://www.globecom.se/tora/"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ mysql? ( >=dev-db/mysql-3.23 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+src_compile() {
+ local myconf
+
+ use kde && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use mysql && myconf="$myconf" \
+ || myconf="$myconf --without-mysql"
+# use postgres && myconf="$myconf" \
+# || myconf="$myconf --without-postgres"
+ use oci8 && myconf="$myconf" \
+ || myconf="$myconf --without-oracle"
+
+ #patch -p0 < ${FILESDIR}/tora-${PV}.patch
+
+ ./configure \
+ --prefix=/usr \
+ --with-mono \
+ $myconf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir ${D}/usr/bin
+ make \
+ ROOT=${D} \
+ install || die "make install failed"
+}