summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-11 18:43:17 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-11 18:43:17 +0000
commit5b8e19a5140d0d5c375e7efa9fbf2a5136e427e4 (patch)
treefd4e4eefabdaed5bb8b592da9e37dc7452757c8a /dev-db/tora
parentMask >=dev-libs/libassuan-2.0.0 and >=app-crypt/gpgme-1.3.0 for testing. (diff)
downloadgentoo-2-5b8e19a5140d0d5c375e7efa9fbf2a5136e427e4.tar.gz
gentoo-2-5b8e19a5140d0d5c375e7efa9fbf2a5136e427e4.tar.bz2
gentoo-2-5b8e19a5140d0d5c375e7efa9fbf2a5136e427e4.zip
Remove usage of kde-functions.eclass; clean up ebuilds a bit
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog6
-rw-r--r--dev-db/tora/tora-1.3.21-r1.ebuild33
-rw-r--r--dev-db/tora/tora-2.1.0.ebuild31
-rw-r--r--dev-db/tora/tora-2.1.1.ebuild15
4 files changed, 36 insertions, 49 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index 6d8bc97c47ab..346b8dd91cd2 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.80 2010/01/07 18:21:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.81 2010/01/11 18:43:17 abcd Exp $
+
+ 11 Jan 2010; Jonathan Callen <abcd@gentoo.org> tora-1.3.21-r1.ebuild,
+ tora-2.1.0.ebuild, tora-2.1.1.ebuild:
+ Remove usage of kde-functions.eclass; clean up ebuilds a bit
07 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> tora-2.1.1.ebuild:
amd64 stable wrt #298855
diff --git a/dev-db/tora/tora-1.3.21-r1.ebuild b/dev-db/tora/tora-1.3.21-r1.ebuild
index 149986e0a769..237f90560d46 100644
--- a/dev-db/tora/tora-1.3.21-r1.ebuild
+++ b/dev-db/tora/tora-1.3.21-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.21-r1.ebuild,v 1.12 2009/11/11 16:47:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.21-r1.ebuild,v 1.13 2010/01/11 18:43:17 abcd Exp $
-inherit eutils kde-functions
+inherit eutils
IUSE="oracle debug oci8-instant-client xinerama"
DESCRIPTION="TOra - Toolkit For Oracle"
@@ -44,9 +44,6 @@ src_unpack() {
}
src_compile() {
- set-qtdir 3
- set-kdedir 3
-
# Need to fake out Qt or we'll get sandbox problems
REALHOME="$HOME"
mkdir -p "$T"/fakehome/.kde
@@ -54,28 +51,22 @@ src_compile() {
export HOME="$T/fakehome"
addwrite "${QTDIR}/etc/settings"
- local myconf
- myconf="${myconf} --without-kde"
- myconf="${myconf} $(use_with oracle)"
- myconf="${myconf} $(use_with xinerama)"
-
- if use oci8-instant-client; then
- myconf="$myconf --with-instant-client"
- fi
-
- myconf="$myconf --with-qt-dir=/usr/qt/3"
+ econf \
+ --without-kde \
+ $(use_with oracle) \
+ $(use_with xinerama) \
+ $(use oci8-instant-client && echo --with-instant-client) \
+ --with-qt-dir=/usr/qt/3
- #./configure $myconf || die "configure failed"
- econf $myconf || die "configure failed"
emake -j1 || die "emake failed"
}
src_install() {
- make install DESTDIR="${D}"
+ emake -j1 install DESTDIR="${D}" || die "install failed"
dodoc BUGS INSTALL NEWS README TODO
insinto /usr/share/applications
- doins "${FILESDIR}"/${PN}.desktop
+ doins "${FILESDIR}"/${PN}.desktop || die
insinto /usr/share/pixmaps
- doins "${FILESDIR}"/${PN}.png
+ doins "${FILESDIR}"/${PN}.png || die
}
diff --git a/dev-db/tora/tora-2.1.0.ebuild b/dev-db/tora/tora-2.1.0.ebuild
index 262da131625c..d67b208ed7cd 100644
--- a/dev-db/tora/tora-2.1.0.ebuild
+++ b/dev-db/tora/tora-2.1.0.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.1.0.ebuild,v 1.5 2010/01/02 23:12:38 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.1.0.ebuild,v 1.6 2010/01/11 18:43:17 abcd Exp $
EAPI=2
-inherit eutils kde-functions
+inherit eutils multilib
-IUSE="debug mysql oracle oci8-instant-client postgres"
DESCRIPTION="TOra - Toolkit For Oracle"
HOMEPAGE="http://tora.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -14,12 +13,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="alpha amd64 hppa ~ppc ~sparc x86"
+IUSE="debug mysql oracle oci8-instant-client postgres"
RDEPEND="${DEPEND}"
DEPEND="dev-lang/perl
- x11-libs/qt-sql
- mysql? ( x11-libs/qt-sql[mysql] )
- postgres? ( x11-libs/qt-sql[postgres] )
+ x11-libs/qt-sql[mysql?,postgres?]
x11-libs/qscintilla
oci8-instant-client? (
dev-db/oracle-instantclient-basic
@@ -42,13 +40,6 @@ pkg_setup() {
}
src_configure() {
- # Need to fake out Qt or we'll get sandbox problems
- REALHOME="$HOME"
- mkdir -p "$T"/fakehome/.kde
- mkdir -p "$T"/fakehome/.qt
- export HOME="$T/fakehome"
- addwrite "${QTDIR}/etc/settings"
-
local myconf
if use oracle; then
@@ -64,9 +55,11 @@ src_configure() {
--with-oracle-includes=${ORACLE_HOME}/include "
fi
- myconf="$myconf --with-qt-includes=/usr/include/qt4/ --with-qt-libraries=/usr/lib/qt4/ --with-qt-dir=/usr/lib/qt4"
-
- econf $myconf || die "configure failed"
+ econf \
+ --with-qt-includes=/usr/include/qt4 \
+ --with-qt-libraries=/usr/$(get_libdir)/qt4 \
+ --with-qt-dir=/usr/$(get_libdir)/qt4 \
+ $myconf
}
src_compile() {
@@ -74,11 +67,11 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}"
+ emake -j1 install DESTDIR="${D}" || die "install failed"
dodoc BUGS INSTALL NEWS README TODO
insinto /usr/share/applications
- doins "${FILESDIR}"/${PN}.desktop
+ doins "${FILESDIR}"/${PN}.desktop || die
insinto /usr/share/pixmaps
- doins "${FILESDIR}"/${PN}.png
+ doins "${FILESDIR}"/${PN}.png || die
}
diff --git a/dev-db/tora/tora-2.1.1.ebuild b/dev-db/tora/tora-2.1.1.ebuild
index 811da15919e7..f218c14928fd 100644
--- a/dev-db/tora/tora-2.1.1.ebuild
+++ b/dev-db/tora/tora-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.1.1.ebuild,v 1.4 2010/01/07 18:21:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.1.1.ebuild,v 1.5 2010/01/11 18:43:17 abcd Exp $
EAPI=2
@@ -50,22 +50,21 @@ src_prepare() {
}
src_configure() {
+ local mycmakeargs=()
if use oracle || use oci8-instant-client ; then
- mycmakeargs+=" -DENABLE_ORACLE=ON"
+ mycmakeargs=(-DENABLE_ORACLE=ON)
else
- mycmakeargs+=" -DENABLE_ORACLE=OFF"
+ mycmakeargs=(-DENABLE_ORACLE=OFF)
fi
- mycmakeargs+="
+ mycmakeargs+=(
-DWANT_RPM=OFF
-DWANT_BUNDLE=OFF
-DWANT_BUNDLE_STANDALONE=OFF
-DWANT_INTERNAL_QSCINTILLA=OFF
$(cmake-utils_use_enable postgres PGSQL)
$(cmake-utils_use_want debug)
- "
- # path variables
- mycmakeargs+="
+ # path variables
-DTORA_DOC_DIR=share/doc/${PF}
- "
+ )
cmake-utils_src_configure
}