summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-04-22 07:57:33 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-04-22 07:57:33 +0000
commitf4b554264287240b7d66b519c570825ac53ea341 (patch)
tree86cd26a3bf020e6dd0da43ff5ee1d6ec10c01f37 /dev-db/tora
parentnew version, closing bug #15398 (diff)
downloadgentoo-2-f4b554264287240b7d66b519c570825ac53ea341.tar.gz
gentoo-2-f4b554264287240b7d66b519c570825ac53ea341.tar.bz2
gentoo-2-f4b554264287240b7d66b519c570825ac53ea341.zip
new version, closing bug #15398
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog11
-rw-r--r--dev-db/tora/Manifest4
-rw-r--r--dev-db/tora/files/digest-tora-1.3.9.21
-rw-r--r--dev-db/tora/tora-1.3.9.2.ebuild48
4 files changed, 60 insertions, 4 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index d83baf9875a3..d900b52e5600 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/tora
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.4 2003/02/12 05:50:07 vapier Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.5 2003/04/22 07:57:26 phosphan Exp $
+
+*tora-1.3.9.2 (22 Apr 2003)
+
+ 22 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> :
+ Version bump, cleaned up dependencies
+ Closing bug #15398
*tora-1.3.8 (31 Oct 2002)
diff --git a/dev-db/tora/Manifest b/dev-db/tora/Manifest
index e27b473d3455..2acf9f59c075 100644
--- a/dev-db/tora/Manifest
+++ b/dev-db/tora/Manifest
@@ -1,7 +1,7 @@
MD5 d7773344200693e9ca9c64cd5c062a55 tora-1.3.6.1.ebuild 1183
MD5 65310eabe1ad17c7f0a09fc99b134c3b tora-1.3.8.ebuild 1695
-MD5 a8a2a5d4cda270d1e3ec833aeaf9a694 tora-1.3.9.2.ebuild 1424
-MD5 b4746cf7a99db005e8a3c51b140fd271 ChangeLog 1063
+MD5 7a70d9feca58a87acc5bc4215a0a063e tora-1.3.9.2.ebuild 1428
+MD5 8ff86aeb6f9a6c28c17b1af1ad2e0f99 ChangeLog 1065
MD5 8f6e10065f5b2ee68338781b0cca4494 tora-1.3.7.ebuild 1182
MD5 f3bd66e811bd9c38f24eb365baa508de files/digest-tora-1.3.6.1 71
MD5 94ba94945d843ea598f9b63230f31e8d files/digest-tora-1.3.9.2 71
diff --git a/dev-db/tora/files/digest-tora-1.3.9.2 b/dev-db/tora/files/digest-tora-1.3.9.2
new file mode 100644
index 000000000000..5868516292ea
--- /dev/null
+++ b/dev-db/tora/files/digest-tora-1.3.9.2
@@ -0,0 +1 @@
+MD5 b251fea4d9786c38594267de7f2ea80a tora-alpha-1.3.9.2.tar.gz 2406008
diff --git a/dev-db/tora/tora-1.3.9.2.ebuild b/dev-db/tora/tora-1.3.9.2.ebuild
new file mode 100644
index 000000000000..76988a86b4a2
--- /dev/null
+++ b/dev-db/tora/tora-1.3.9.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.9.2.ebuild,v 1.1 2003/04/22 07:57:26 phosphan Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TOra - Toolkit For Oracle"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+HOMEPAGE="http://www.globecom.se/tora/"
+DEPEND=">=x11-libs/qt-3.0.0
+ dev-lang/perl
+ mysql? ( >=dev-db/mysql-3.23 )
+ kde? ( >=kde-base/kde-2.2 )"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+src_compile() {
+ local myconf
+
+ use kde && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use mysql || myconf="$myconf --without-mysql"
+ use oci8 || myconf="$myconf --without-oracle"
+
+ ./configure --prefix=/usr --with-mono $myconf
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir ${D}/usr/bin
+ einstall ROOT=${D}
+}
+
+pkg_setup () {
+
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}