summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-03 16:12:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-03 16:12:07 +0000
commit6cc0831d0752e5a8909c43887cee783b4143b96d (patch)
tree77f0d842efd7bff2fb085b7a2d4a84cf150d8a07 /dev-db/unixODBC
parentAdd whitelisted ruby_targets_ree18 masking (diff)
downloadgentoo-2-6cc0831d0752e5a8909c43887cee783b4143b96d.tar.gz
gentoo-2-6cc0831d0752e5a8909c43887cee783b4143b96d.tar.bz2
gentoo-2-6cc0831d0752e5a8909c43887cee783b4143b96d.zip
New USE flag odbcmanual to control documentation installation (we don't want to pollute USE doc). Link to unixODBC Qt4 GUI project. Install PREFIX related docs only when required. Make ebuild readable and leave it to maintainer-needed.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog9
-rw-r--r--dev-db/unixODBC/metadata.xml8
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.0.ebuild43
3 files changed, 48 insertions, 12 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index b38140872752..38863ab1c8ed 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/unixODBC
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.80 2010/05/02 19:33:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.81 2010/05/03 16:12:07 ssuominen Exp $
+
+ 03 May 2010; Samuli Suominen <ssuominen@gentoo.org> unixODBC-2.3.0.ebuild,
+ metadata.xml:
+ New USE flag odbcmanual to control documentation installation (we don't
+ want to pollute USE doc). Link to unixODBC Qt4 GUI project. Install PREFIX
+ related docs only when required. Make ebuild readable and leave it to
+ maintainer-needed.
02 May 2010; Samuli Suominen <ssuominen@gentoo.org> unixODBC-2.3.0.ebuild:
Pass --disable-drivers and --disable-driver-conf per upstream default in
diff --git a/dev-db/unixODBC/metadata.xml b/dev-db/unixODBC/metadata.xml
index 019beda5e9aa..a52a84acb90f 100644
--- a/dev-db/unixODBC/metadata.xml
+++ b/dev-db/unixODBC/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>php</herd>
+ <herd>no-herd</herd>
<maintainer>
- <email>ssuominen@gentoo.org</email>
- <name>Samuli Suominen</name>
+ <email>maintainer-needed@gentoo.org</email>
</maintainer>
<use>
- <flag name="minimal">Don't build and install bundled drivers and extra libraries</flag>
+ <flag name="minimal">Disable bundled drivers and extra libraries (most users don't need these)</flag>
+ <flag name="odbcmanual">Administrator, Internal Structure, Programmer and User documentation</flag>
</use>
</pkgmetadata>
diff --git a/dev-db/unixODBC/unixODBC-2.3.0.ebuild b/dev-db/unixODBC/unixODBC-2.3.0.ebuild
index 81d72c57471e..d814a298cd2b 100644
--- a/dev-db/unixODBC/unixODBC-2.3.0.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.3.0.ebuild,v 1.2 2010/05/02 19:33:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.3.0.ebuild,v 1.3 2010/05/03 16:12:07 ssuominen Exp $
EAPI=3
inherit libtool
@@ -12,19 +12,23 @@ SRC_URI="mirror://sourceforge/unixodbc/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="+minimal static-libs"
+IUSE="+minimal odbcmanual static-libs"
-RDEPEND=">=sys-libs/readline-6.0
- >=sys-libs/ncurses-5.6
- >=sys-devel/libtool-2.2.6b"
+# needed by libltdl
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ >=sys-libs/readline-6.0_p4
+ >=sys-libs/ncurses-5.6-r2"
+# need to set explicitely, flex will be out of system set in future
DEPEND="${RDEPEND}
sys-devel/flex"
src_prepare() {
+ # needed by gfbsd
elibtoolize
}
src_configure() {
+ # fixme: drivers are full of missing string.h includes
econf \
--sysconfdir="${EPREFIX}/etc/${PN}" \
--disable-dependency-tracking \
@@ -35,7 +39,32 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
- dodoc AUTHORS ChangeLog NEWS README*
- dohtml -a css,gif,html,sql,vsd -r doc/*
+ if use prefix; then
+ dodoc README* || die
+ fi
+
+ # avoid abusing too generic USE doc
+ if use odbcmanual; then
+ dohtml -a css,gif,html,sql,vsd -r doc/* || die
+ fi
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ einfo
+ einfo "Qt4 frontend moved to:"
+ einfo "http://sourceforge.net/projects/unixodbc-gui-qt/"
+ einfo
+ einfo "Please don't open bugs about it before they do a file release."
+ einfo
+ fi
+
+ # feel free to punt this warning after some time
+ ewarn "If you are upgrading from unixODBC 2.2.12 or 2.2.14 to 2.3.0,"
+ ewarn "it's good idea to re-emerge all unixODBC reverse dependencies now."
+ ewarn "See,"
+ ewarn "http://tinderbox.x86.dev.gentoo.org/misc/rindex/dev-db/unixODBC"
+ ewarn "http://tinderbox.x86.dev.gentoo.org/misc/dindex/dev-db/unixODBC"
}