summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-04-10 00:55:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-04-10 00:55:07 +0000
commit0071e627d1e52a4fa7ca9f557532bf755a07e218 (patch)
tree7bc77a9d2a9d1e63e693e40d57127e0830e9f6c1 /dev-db
parentAlter version numbering to include full branch number, so we can introduce th... (diff)
downloadgentoo-2-0071e627d1e52a4fa7ca9f557532bf755a07e218.tar.gz
gentoo-2-0071e627d1e52a4fa7ca9f557532bf755a07e218.tar.bz2
gentoo-2-0071e627d1e52a4fa7ca9f557532bf755a07e218.zip
Accidently removed my work that should have committed due to bad hotel wifi. Sorry. Add the last version of 7.0 back instead now, was all ~arch anyway.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/drizzle/ChangeLog9
-rw-r--r--dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild174
2 files changed, 182 insertions, 1 deletions
diff --git a/dev-db/drizzle/ChangeLog b/dev-db/drizzle/ChangeLog
index a0efda65bd84..4c4c13b9cc7a 100644
--- a/dev-db/drizzle/ChangeLog
+++ b/dev-db/drizzle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/drizzle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/ChangeLog,v 1.25 2012/04/10 00:30:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/ChangeLog,v 1.26 2012/04/10 00:55:07 robbat2 Exp $
+
+*drizzle-7.0.2011.03.13 (10 Apr 2012)
+
+ 10 Apr 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +drizzle-7.0.2011.03.13.ebuild:
+ Accidently removed my work that should have committed due to bad hotel wifi.
+ Sorry. Add the last version of 7.0 back instead now, was all ~arch anyway.
*drizzle-7.1.33 (10 Apr 2012)
diff --git a/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild b/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild
new file mode 100644
index 000000000000..30c3de5bb077
--- /dev/null
+++ b/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild,v 1.1 2012/04/10 00:55:07 robbat2 Exp $
+
+EAPI=2
+
+inherit flag-o-matic libtool autotools eutils pam versionator
+
+# Upstream version numbers live in a directory that is [+-][1-2] days either
+# side of the name the tarball! eg:
+# https://launchpad.net/drizzle/7.0/2011-03-14/+download/drizzle7-2011.03.13.tar.gz
+# If the tarball falls on the last day of the month, be really careful!
+# We name the ebuild for the tarball, and deal with the mess of the name instead
+
+MY_PN="${PN}$(get_version_component_range 1-1)"
+MY_PV="$(get_version_component_range 3-5)"
+MY_P="${MY_PN}-${MY_PV}"
+
+# This is the mess of the name
+DIR_PV_B="$(get_version_component_range 1-2)"
+DIR_PV_DATE="2011-03-14"
+DIR_PV="${DIR_PV_B}/${DIR_PV_DATE}"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Database optimized for Cloud and Net applications"
+HOMEPAGE="http://drizzle.org"
+SRC_URI="http://launchpad.net/drizzle/${DIR_PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcmalloc doc memcache curl pam gearman +md5 ldap haildb"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ sys-libs/readline
+ sys-apps/util-linux
+ dev-libs/libpcre
+ >=dev-libs/libevent-1.4
+ >=dev-libs/protobuf-2.1.0
+ gearman? ( >=sys-cluster/gearmand-0.12 )
+ pam? ( sys-libs/pam )
+ curl? ( net-misc/curl )
+ memcache? ( >=dev-libs/libmemcached-0.39 )
+ md5? ( >=dev-libs/libgcrypt-1.4.2 )
+ haildb? ( >=dev-db/haildb-2.3.2 )
+ >=dev-libs/boost-1.32
+ ldap? ( net-nds/openldap )
+ !dev-db/libdrizzle"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/gperf
+ sys-devel/flex
+ doc? ( app-doc/doxygen )
+ >=dev-util/boost-build-1.32"
+
+pkg_setup() {
+ enewuser drizzle -1 -1 /dev/null nogroup
+}
+
+src_prepare() {
+ #epatch "${FILESDIR}/${PN}-2009.12.1240-nolint.patch"
+
+ AT_M4DIR="m4" eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ local myconf=
+
+ if use debug; then
+ append-flags -DDEBUG
+ fi
+
+ # while I applaud upstreams goal of 0 compiler warnings
+ # the 1412 release didn't achieve it.
+ append-flags -Wno-error
+
+ # Bug #362901
+ append-flags -DBOOST_FILESYSTEM_VERSION=2
+
+ # NOTE disable-all and without-all no longer recognized options
+ # NOTE using --enable on some plugins can cause test failures.
+ # --with should be used instead. A discussion about this here:
+ # https://bugs.launchpad.net/drizzle/+bug/598659
+ # TODO (upstream)
+ # $(use_with memcache memcached-stats-plugin) \
+ # $(use_with memcache memcached-functions-plugin) \
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ $(use_enable tcmalloc) \
+ $(use_enable memcache libmemcached) \
+ $(use_enable gearman libgearman) \
+ $(use_enable ldap libldap) \
+ $(use_with curl auth-http-plugin) \
+ $(use_with pam auth-pam-plugin) \
+ $(use_with md5 md5-plugin) \
+ $(use_with gearman gearman-udf-plugin) \
+ $(use_with gearman logging-gearman-plugin) \
+ $(use_with ldap auth-ldap-plugin) \
+ --without-hello-world-plugin \
+ --disable-pbxt-plugin --without-pbxt-plugin \
+ --disable-rabbitmq-plugin --without-rabbitmq-plugin \
+ $(use_enable haildb libhaildb) \
+ $(use_enable haildb haildb-plugin) \
+ $(use_with haildb haildb-plugin) \
+ --with-auth-test-plugin \
+ --with-auth-file-plugin \
+ --with-simple-user-policy-plugin \
+ --enable-logging-stats-plugin \
+ --with-logging-stats-plugin \
+ --enable-console-plugin \
+ --enable-archive-plugin \
+ ${myconf}
+
+}
+
+src_compile() {
+ emake all $(use doc && echo doxygen) || die "build failed"
+}
+
+# 5-10 min eta
+src_test() {
+ # If you want to turn off a test, rename to suffix of .DISABLED
+ # Explicitly allow parallel make check
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README || die
+
+ find "${D}" -name '*.la' -delete || die
+
+ if use doc; then
+ docinto apidoc
+ pushd docs/html
+ dohtml -r .
+ popd
+ fi
+
+ newinitd "${FILESDIR}"/drizzle.init.d drizzled || die
+ newconfd "${FILESDIR}"/drizzle.conf.d drizzled || die
+
+ if ! use gearman; then
+ sed -i -e '/need gearmand/d' "${D}"/etc/init.d/drizzled \
+ || die "unable to sed init script (gearman)"
+ fi
+
+ if ! use memcache; then
+ sed -i -e '/need memcached/d' "${D}"/etc/init.d/drizzled \
+ || die "unable to sed init script (memcache)"
+ fi
+
+ keepdir /var/run/drizzle || die
+ keepdir /var/log/drizzle || die
+ keepdir /var/lib/drizzle/drizzled || die
+ keepdir /etc/drizzle || die
+
+ fperms 0755 /var/run/drizzle || die
+ fperms 0755 /var/log/drizzle || die
+ fperms -R 0700 /var/lib/drizzle || die
+
+ fowners drizzle:nogroup /var/run/drizzle || die
+ fowners drizzle:nogroup /var/log/drizzle || die
+ fowners -R drizzle:nogroup /var/lib/drizzle || die
+
+ pamd_mimic system-auth drizzle auth account session
+}