summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-12-04 22:02:30 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-12-04 22:02:30 +0000
commit340c295cdc7aeba45a13b500157af8dbda74a4d6 (patch)
tree8d69f81daa7eed1771225e376fd7acbf1b712461 /dev-db
parentbetter error (diff)
downloadgentoo-2-340c295cdc7aeba45a13b500157af8dbda74a4d6.tar.gz
gentoo-2-340c295cdc7aeba45a13b500157af8dbda74a4d6.tar.bz2
gentoo-2-340c295cdc7aeba45a13b500157af8dbda74a4d6.zip
initial ebuild
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite-php/ChangeLog7
-rw-r--r--dev-db/sqlite-php/files/digest-sqlite-php-0.0.51
-rw-r--r--dev-db/sqlite-php/sqlite-php-0.0.5.ebuild39
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/sqlite-php/ChangeLog b/dev-db/sqlite-php/ChangeLog
new file mode 100644
index 000000000000..a82bfdfceeb4
--- /dev/null
+++ b/dev-db/sqlite-php/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-db/sqlite
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite-php/ChangeLog,v 1.1 2002/12/04 22:02:30 verwilst Exp $
+
+*sqlite-php-0.0.5 (4 December 2002) Bart Verwilst <verwilst@gentoo.org>
+
+ initial ebuild
diff --git a/dev-db/sqlite-php/files/digest-sqlite-php-0.0.5 b/dev-db/sqlite-php/files/digest-sqlite-php-0.0.5
new file mode 100644
index 000000000000..994332b74e1c
--- /dev/null
+++ b/dev-db/sqlite-php/files/digest-sqlite-php-0.0.5
@@ -0,0 +1 @@
+MD5 696f0d0b65f57c63293e3386acfdf094 sqlite-php-0.0.5.tgz 5521
diff --git a/dev-db/sqlite-php/sqlite-php-0.0.5.ebuild b/dev-db/sqlite-php/sqlite-php-0.0.5.ebuild
new file mode 100644
index 000000000000..df39663f80de
--- /dev/null
+++ b/dev-db/sqlite-php/sqlite-php-0.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite-php/sqlite-php-0.0.5.ebuild,v 1.1 2002/12/04 22:02:30 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PHP bindings for SQLite"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://sourceforge.net/projects/sqlite-php/"
+DEPEND="virtual/glibc
+ >=dev-php/php-4.2
+ >=dev-db/sqlite-2.7"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+
+ phpize
+ ./configure --host=${CHOST} --with-sqlite=shared || die
+ make || die
+
+}
+
+src_install () {
+
+ mkdir -p ${D}/usr/lib/apache-extramodules
+ cp ${S}/modules/sqlite.so ${D}/usr/lib/apache-extramodules
+ dodoc README CREDITS CHANGES
+
+}
+
+pkg_postinst() {
+
+ echo " "
+ einfo "You will need to add "extension=sqlite.so" to php.ini first."
+ echo " "
+
+}