summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-04-19 20:40:42 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-04-19 20:40:42 +0000
commit36c1d2626f8a0d0c4fe0425079ce645519d734fd (patch)
tree1cee55c8d19553c4101112ad78c96d8bf0071ada /dev-db
parentUpdated patch for 8.3 (accidentally disabled tsearch2, thanks to Elvis Pransk... (diff)
downloadgentoo-2-36c1d2626f8a0d0c4fe0425079ce645519d734fd.tar.gz
gentoo-2-36c1d2626f8a0d0c4fe0425079ce645519d734fd.tar.bz2
gentoo-2-36c1d2626f8a0d0c4fe0425079ce645519d734fd.zip
Removed libedit USE-flag since I experienced memory leaks when having psql linked against libedit.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql-base/ChangeLog7
-rw-r--r--dev-db/postgresql-base/postgresql-base-8.2.7.ebuild24
-rw-r--r--dev-db/postgresql-base/postgresql-base-8.3.1.ebuild24
3 files changed, 16 insertions, 39 deletions
diff --git a/dev-db/postgresql-base/ChangeLog b/dev-db/postgresql-base/ChangeLog
index 94a01ed83a7b..76eea5b5ba7b 100644
--- a/dev-db/postgresql-base/ChangeLog
+++ b/dev-db/postgresql-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/postgresql-base
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.1 2008/04/15 09:23:34 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.2 2008/04/19 20:40:42 dev-zero Exp $
+
+ 19 Apr 2008; Tiziano Müller <dev-zero@gentoo.org>
+ postgresql-base-8.2.7.ebuild, postgresql-base-8.3.1.ebuild:
+ Removed libedit USE-flag since I experienced memory leaks when having psql
+ linked against libedit.
*postgresql-base-8.3.1 (15 Apr 2008)
*postgresql-base-8.2.7 (15 Apr 2008)
diff --git a/dev-db/postgresql-base/postgresql-base-8.2.7.ebuild b/dev-db/postgresql-base/postgresql-base-8.2.7.ebuild
index 3df209596a4a..014dd99e89a7 100644
--- a/dev-db/postgresql-base/postgresql-base-8.2.7.ebuild
+++ b/dev-db/postgresql-base/postgresql-base-8.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.2.7.ebuild,v 1.1 2008/04/15 09:23:34 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.2.7.ebuild,v 1.2 2008/04/19 20:40:42 dev-zero Exp $
EAPI="1"
@@ -21,7 +21,7 @@ IUSE_LINGUAS="
linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
linguas_tr linguas_zh_CN linguas_zh_TW"
-IUSE="doc kerberos libedit nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
+IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
RESTRICT="test"
wanted_languages() {
@@ -32,8 +32,7 @@ wanted_languages() {
RDEPEND="kerberos? ( virtual/krb5 )
pam? ( virtual/pam )
- readline? ( !libedit? ( >=sys-libs/readline-4.1 ) )
- libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1 )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
zlib? ( >=sys-libs/zlib-1.1.3 )
>=app-admin/eselect-postgresql-0.3
@@ -49,14 +48,6 @@ PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
S="${WORKDIR}/postgresql-${PV}"
-pkg_setup() {
- if use readline && use libedit ; then
- ewarn "PostgreSQL can use libedit OR readline but not both, libedit"
- ewarn "will be used. If that is not what you want, please stop the"
- ewarn "merge and unset the 'libedit' USE-flag for ${PN}."
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -75,13 +66,6 @@ src_unpack() {
}
src_compile() {
- local myconf
- if use readline || use libedit ; then
- myconf="${myconf} --with-readline $(use_with libedit libedit-preferred)"
- else
- myconf="${myconf} --without-readline"
- fi
-
econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
--datadir=/usr/share/postgresql-${SLOT} \
--sysconfdir=/etc/postgresql-${SLOT} \
@@ -93,6 +77,8 @@ src_compile() {
--without-tcl \
--without-perl \
--without-python \
+ --without-libedit \
+ $(use_with readline) \
$(use_with kerberos krb5) \
"$(use_enable nls nls "$(wanted_languages)")" \
$(use_with pam) \
diff --git a/dev-db/postgresql-base/postgresql-base-8.3.1.ebuild b/dev-db/postgresql-base/postgresql-base-8.3.1.ebuild
index 1611e7690109..4a75383c47f8 100644
--- a/dev-db/postgresql-base/postgresql-base-8.3.1.ebuild
+++ b/dev-db/postgresql-base/postgresql-base-8.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.3.1.ebuild,v 1.1 2008/04/15 09:23:34 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-8.3.1.ebuild,v 1.2 2008/04/19 20:40:42 dev-zero Exp $
EAPI="1"
@@ -21,7 +21,7 @@ IUSE_LINGUAS="
linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
linguas_tr linguas_zh_CN linguas_zh_TW"
-IUSE="doc kerberos libedit nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
+IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
RESTRICT="test"
wanted_languages() {
@@ -32,8 +32,7 @@ wanted_languages() {
RDEPEND="kerberos? ( virtual/krb5 )
pam? ( virtual/pam )
- readline? ( !libedit? ( >=sys-libs/readline-4.1 ) )
- libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1 )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
zlib? ( >=sys-libs/zlib-1.1.3 )
>=app-admin/eselect-postgresql-0.3
@@ -49,14 +48,6 @@ PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
S="${WORKDIR}/postgresql-${PV}"
-pkg_setup() {
- if use readline && use libedit ; then
- ewarn "PostgreSQL can use libedit OR readline but not both, libedit"
- ewarn "will be used. If that is not what you want, please stop the"
- ewarn "merge and unset the 'libedit' USE-flag for ${PN}."
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -75,13 +66,6 @@ src_unpack() {
}
src_compile() {
- local myconf
- if use readline || use libedit ; then
- myconf="${myconf} --with-readline $(use_with libedit libedit-preferred)"
- else
- myconf="${myconf} --without-readline"
- fi
-
econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
--datadir=/usr/share/postgresql-${SLOT} \
--sysconfdir=/etc/postgresql-${SLOT} \
@@ -93,6 +77,8 @@ src_compile() {
--without-tcl \
--without-perl \
--without-python \
+ --without-libedit \
+ $(use_with readline) \
$(use_with kerberos krb5) \
$(use_with kerberos gssapi) \
"$(use_enable nls nls "$(wanted_languages)")" \