summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-07-29 03:24:47 +0000
committerBrian Evans <grknight@gentoo.org>2014-07-29 03:24:47 +0000
commit389a66d4988926156e7d91d9c704ae9059c85105 (patch)
tree6dc8a10a2f2ac9e96bab2ae6844d16a9dc7fdcc2 /dev-db
parentbump; add py3.4 support drop keywords alpha ia64 ppc64 sparc to allow adding ... (diff)
downloadgentoo-2-389a66d4988926156e7d91d9c704ae9059c85105.tar.gz
gentoo-2-389a66d4988926156e7d91d9c704ae9059c85105.tar.bz2
gentoo-2-389a66d4988926156e7d91d9c704ae9059c85105.zip
Revision bump to fix symbols needed by dev-db/myodbc:5.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog8
-rw-r--r--dev-db/mysql/mysql-5.5.37-r1.ebuild135
-rw-r--r--dev-db/mysql/mysql-5.5.38-r1.ebuild (renamed from dev-db/mysql/mysql-5.5.38.ebuild)4
3 files changed, 9 insertions, 138 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 44ce7ca24423..7fbadf5d8999 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.672 2014/07/19 10:27:34 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.673 2014/07/29 03:24:47 grknight Exp $
+
+*mysql-5.5.38-r1 (29 Jul 2014)
+
+ 29 Jul 2014; Brian Evans <grknight@gentoo.org> +mysql-5.5.38-r1.ebuild,
+ -mysql-5.5.37-r1.ebuild, -mysql-5.5.38.ebuild:
+ Revision bump to fix symbols needed by dev-db/myodbc:5.2
19 Jul 2014; Fabian Groffen <grobian@gentoo.org> mysql-5.5.38.ebuild:
Add Prefix keywords from virtual
diff --git a/dev-db/mysql/mysql-5.5.37-r1.ebuild b/dev-db/mysql/mysql-5.5.37-r1.ebuild
deleted file mode 100644
index 673c128f8314..000000000000
--- a/dev-db/mysql/mysql-5.5.37-r1.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.5.37-r1.ebuild,v 1.1 2014/04/26 05:36:06 jmbsvicetto Exp $
-
-EAPI="4"
-
-MY_EXTRAS_VER="20140426-0232Z"
-MY_PV="${PV//_alpha_pre/-m}"
-MY_PV="${MY_PV//_/-}"
-
-# Build type
-BUILD="cmake"
-
-inherit toolchain-funcs mysql-v2
-# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
-
-# Define the mysql-extras source
-EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
-
-# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux"
-
-# When MY_EXTRAS is bumped, the index should be revised to exclude these.
-EPATCH_EXCLUDE=''
-
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
-RDEPEND="${RDEPEND}"
-
-# Please do not add a naive src_unpack to this ebuild
-# If you want to add a single patch, copy the ebuild to an overlay
-# and create your own mysql-extras tarball, looking at 000_index.txt
-
-# Official test instructions:
-# USE='-cluster embedded extraengine perl ssl static-libs community' \
-# FEATURES='test userpriv -usersandbox' \
-# ebuild mysql-X.X.XX.ebuild \
-# digest clean package
-src_test() {
-
- local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test"
- local retstatus_unit
- local retstatus_tests
-
- # Bug #213475 - MySQL _will_ object strenously if your machine is named
- # localhost. Also causes weird failures.
- [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
-
- if ! use "minimal" ; then
-
- if [[ $UID -eq 0 ]]; then
- die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
- fi
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- addpredict /this-dir-does-not-exist/t9.MYI
-
- # Run CTest (test-units)
- cmake-utils_src_test
- retstatus_unit=$?
- [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
-
- # Ensure that parallel runs don't die
- export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
-
- # create directories because mysqladmin might right out of order
- mkdir -p "${S}"/mysql-test/var-tests{,/log}
-
- # create symlink for the tests to find mysql_tzinfo_to_sql
- ln -s "${CMAKE_BUILD_DIR}/sql/mysql_tzinfo_to_sql" "${S}/sql/"
-
- # These are failing in MySQL 5.5 for now and are believed to be
- # false positives:
- #
- # main.information_schema, binlog.binlog_statement_insert_delayed,
- # main.mysqld--help-notwin
- # fails due to USE=-latin1 / utf8 default
- #
- # main.mysql_client_test:
- # segfaults at random under Portage only, suspect resource limits.
- #
- # sys_vars.plugin_dir_basic
- # fails because PLUGIN_DIR is set to MYSQL_LIBDIR64/plugin
- # instead of MYSQL_LIBDIR/plugin
- #
- # main.flush_read_lock_kill
- # fails because of unknown system variable 'DEBUG_SYNC'
- #
- # main.openssl_1
- # error message changing
- # -mysqltest: Could not open connection 'default': 2026 SSL connection
- # error: ASN: bad other signature confirmation
- # +mysqltest: Could not open connection 'default': 2026 SSL connection
- # error: error:00000001:lib(0):func(0):reason(1)
- #
- # main.mysql_tzinfo_to_sql_symlink
- # fails due to missing mysql_test/std_data/zoneinfo/GMT file from archive
-
- for t in main.mysql_client_test \
- binlog.binlog_statement_insert_delayed main.information_schema \
- main.mysqld--help-notwin main.flush_read_lock_kill \
- sys_vars.plugin_dir_basic main.openssl_1 mysql_tzinfo_to_sql_symlink ; do
- mysql-v2_disable_test "$t" "False positives in Gentoo"
- done
-
- # Run mysql tests
- pushd "${TESTDIR}"
-
- # run mysql-test tests
- perl mysql-test-run.pl --force --vardir="${S}/mysql-test/var-tests" \
- --testcase-timeout=30
- retstatus_tests=$?
- [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- popd
-
- # Cleanup is important for these testcases.
- pkill -9 -f "${S}/ndb" 2>/dev/null
- pkill -9 -f "${S}/sql" 2>/dev/null
-
- failures=""
- [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
- [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- [[ -z "$failures" ]] || die "Test failures: $failures"
- einfo "Tests successfully completed"
-
- else
-
- einfo "Skipping server tests due to minimal build."
- fi
-}
diff --git a/dev-db/mysql/mysql-5.5.38.ebuild b/dev-db/mysql/mysql-5.5.38-r1.ebuild
index 3832c2ae1ece..cbfa27f58911 100644
--- a/dev-db/mysql/mysql-5.5.38.ebuild
+++ b/dev-db/mysql/mysql-5.5.38-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.5.38.ebuild,v 1.2 2014/07/19 10:27:34 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.5.38-r1.ebuild,v 1.1 2014/07/29 03:24:47 grknight Exp $
EAPI="5"
-MY_EXTRAS_VER="20140426-0232Z"
+MY_EXTRAS_VER="20140729-0112Z"
MY_PV="${PV//_alpha_pre/-m}"
MY_PV="${MY_PV//_/-}"