summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-10-15 16:40:45 +0000
committerBrian Evans <grknight@gentoo.org>2014-10-15 16:40:45 +0000
commit5a7cdd05a9c6e32675010df41a60ab8cfc9c0772 (patch)
tree08fe8c33d180e71408cfb978c80eb3c9ebd86c54 /dev-db
parentversion bump; fix build (verbosity and compiler used) wrt bugs 524338 524340,... (diff)
downloadgentoo-2-5a7cdd05a9c6e32675010df41a60ab8cfc9c0772.tar.gz
gentoo-2-5a7cdd05a9c6e32675010df41a60ab8cfc9c0772.tar.bz2
gentoo-2-5a7cdd05a9c6e32675010df41a60ab8cfc9c0772.zip
Drop old
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mariadb/ChangeLog5
-rw-r--r--dev-db/mariadb/mariadb-10.0.12.ebuild113
2 files changed, 4 insertions, 114 deletions
diff --git a/dev-db/mariadb/ChangeLog b/dev-db/mariadb/ChangeLog
index 714f6cde913f..8ef917f944a1 100644
--- a/dev-db/mariadb/ChangeLog
+++ b/dev-db/mariadb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/mariadb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/ChangeLog,v 1.58 2014/10/09 19:56:00 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/ChangeLog,v 1.59 2014/10/15 16:40:45 grknight Exp $
+
+ 15 Oct 2014; Brian Evans <grknight@gentoo.org> -mariadb-10.0.12.ebuild:
+ Drop old
*mariadb-5.5.40 (09 Oct 2014)
diff --git a/dev-db/mariadb/mariadb-10.0.12.ebuild b/dev-db/mariadb/mariadb-10.0.12.ebuild
deleted file mode 100644
index 97c92b9e2981..000000000000
--- a/dev-db/mariadb/mariadb-10.0.12.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/mariadb-10.0.12.ebuild,v 1.5 2014/10/02 02:32:22 grknight Exp $
-
-EAPI="5"
-MY_EXTRAS_VER="20140729-2200Z"
-
-# Build system
-BUILD="cmake"
-
-inherit toolchain-funcs mysql-v2
-# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
-
-# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-# When MY_EXTRAS is bumped, the index should be revised to exclude these.
-EPATCH_EXCLUDE=''
-
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
-RDEPEND="${RDEPEND}"
-
-# Official test instructions:
-# USE='-cluster embedded extraengine perl ssl static-libs community' \
-# FEATURES='test userpriv -usersandbox' \
-# ebuild mariadb-X.X.XX.ebuild \
-# digest clean package
-src_test() {
-
- local TESTDIR="${BUILD_DIR}/mysql-test"
- local retstatus_unit
- local retstatus_tests
-
- # Bug #213475 - MySQL _will_ object strenously if your machine is named
- # localhost. Also causes weird failures.
- [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
-
- if ! use "minimal" ; then
-
- if [[ $UID -eq 0 ]]; then
- die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
- fi
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- addpredict /this-dir-does-not-exist/t9.MYI
-
- # Run CTest (test-units)
- cmake-utils_src_test
- retstatus_unit=$?
- [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
-
- # Ensure that parallel runs don't die
- export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
-
- # create directories because mysqladmin might right out of order
- mkdir -p "${S}"/mysql-test/var-tests{,/log}
-
- # These are failing in MariaDB 10.0 for now and are believed to be
- # false positives:
- #
- # main.information_schema, binlog.binlog_statement_insert_delayed,
- # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
- # funcs_1.is_columns_mysql
- # fails due to USE=-latin1 / utf8 default
- #
- # main.mysql_client_test, main.mysql_client_test_nonblock:
- # segfaults at random under Portage only, suspect resource limits.
- #
- # plugins.unix_socket
- # fails because portage strips out the USER enviornment variable
- #
-
- for t in main.mysql_client_test main.mysql_client_test_nonblock \
- binlog.binlog_statement_insert_delayed main.information_schema \
- main.mysqld--help plugins.unix_socket \
- funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
- mysql-v2_disable_test "$t" "False positives in Gentoo"
- done
-
- # Run mysql tests
- pushd "${TESTDIR}"
-
- # run mysql-test tests
- # Skip all CONNECT engine tests until upstream respondes to how to reference data files
- perl mysql-test-run.pl --force --vardir="${S}/mysql-test/var-tests" \
- --skip-test=connect --parallel=auto
- retstatus_tests=$?
- [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- popd
-
- # Cleanup is important for these testcases.
- pkill -9 -f "${S}/ndb" 2>/dev/null
- pkill -9 -f "${S}/sql" 2>/dev/null
-
- failures=""
- [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
- [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- [[ -z "$failures" ]] || die "Test failures: $failures"
- einfo "Tests successfully completed"
-
- # Cleanup data files after tests
- rm -r "${S}/mysql-test/var-tests" || die "Cleanup failed"
- else
-
- einfo "Skipping server tests due to minimal build."
- fi
-}