summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-01 21:56:57 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-01 21:56:57 +0000
commit760660fc7737d5d50795288ca874cb6c09bf10f4 (patch)
tree263691f88e4d7a4326c3f7da2abc8b76de0d9542 /dev-db
parentblocked a few new packages, which I did not yet test (diff)
downloadgentoo-2-760660fc7737d5d50795288ca874cb6c09bf10f4.tar.gz
gentoo-2-760660fc7737d5d50795288ca874cb6c09bf10f4.tar.bz2
gentoo-2-760660fc7737d5d50795288ca874cb6c09bf10f4.zip
Bugfix release
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/unixODBC/files/digest-unixODBC-2.0.81
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/unixODBC/files/digest-unixODBC-2.0.8 b/dev-db/unixODBC/files/digest-unixODBC-2.0.8
new file mode 100644
index 000000000000..0462b8c50f1c
--- /dev/null
+++ b/dev-db/unixODBC/files/digest-unixODBC-2.0.8
@@ -0,0 +1 @@
+MD5 8b86e29adc2f3ff0713cde9c1a20c5ec unixODBC-2.0.8.tar.gz
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
new file mode 100644
index 000000000000..cc5309c95ca0
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.1 2001/07/01 21:56:57 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="ODBC Interface for Linux"
+SRC_URI="http://www.unixodbc.org/${A}"
+HOMEPAGE="http://www.unixodbc.org"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-x11-2.3.0 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
+
+}
+src_compile() {
+ local myconf
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+ try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
+
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
+}