summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-01-20 15:59:11 +0000
committerDaniel Drake <dsd@gentoo.org>2006-01-20 15:59:11 +0000
commit4ab7b0fea3f3c546c7a3b6c076221a0f3cdf429f (patch)
tree5bb536fb2ff5176a5db7fcfc4bc01c62d1dbaf07 /dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild
parentAdd 0.4.4 bindings (diff)
downloadgentoo-2-4ab7b0fea3f3c546c7a3b6c076221a0f3cdf429f.tar.gz
gentoo-2-4ab7b0fea3f3c546c7a3b6c076221a0f3cdf429f.tar.bz2
gentoo-2-4ab7b0fea3f3c546c7a3b6c076221a0f3cdf429f.zip
Version bump to 0.7. Also close bug #118950 with a patch.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild')
-rw-r--r--dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild b/dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild
new file mode 100644
index 000000000000..183b1733251e
--- /dev/null
+++ b/dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gsf-sharp/gsf-sharp-0.7.ebuild,v 1.1 2006/01/20 15:59:11 dsd Exp $
+
+inherit eutils mono
+
+DESCRIPTION="C# bindings for libgsf"
+HOMEPAGE="http://www.mono-project.com/"
+SRC_URI="http://primates.ximian.com/~joe/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-lang/mono
+ >=gnome-extra/libgsf-1.13
+ >=dev-dotnet/gtk-sharp-2.3.90"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Bug 118950 - no need to check for libgsf-gnome-1
+ # Committed upstream for next release
+ epatch ${FILESDIR}/${P}-no-libgsf-gnome-dep.patch
+}
+
+src_install() {
+ make install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+