summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-27 02:02:24 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-27 02:02:24 +0000
commitc6ad0f3e8e802208ff2138bcd2bbeeb8d946a50e (patch)
tree98bf3942f7fd29b86440f99f931bb96e0584661d /dev-dotnet/ikvm-bin
parentdev-lang/mono: LC_ALL=C is now being set in mono.eclass (diff)
downloadgentoo-2-c6ad0f3e8e802208ff2138bcd2bbeeb8d946a50e.tar.gz
gentoo-2-c6ad0f3e8e802208ff2138bcd2bbeeb8d946a50e.tar.bz2
gentoo-2-c6ad0f3e8e802208ff2138bcd2bbeeb8d946a50e.zip
dev-dotnet/ikvm-bin: version bump -> 0.34.0.2
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-dotnet/ikvm-bin')
-rw-r--r--dev-dotnet/ikvm-bin/ChangeLog8
-rw-r--r--dev-dotnet/ikvm-bin/files/digest-ikvm-bin-0.34.0.23
-rw-r--r--dev-dotnet/ikvm-bin/files/ikvm.pc.in9
-rw-r--r--dev-dotnet/ikvm-bin/ikvm-bin-0.34.0.2.ebuild40
4 files changed, 59 insertions, 1 deletions
diff --git a/dev-dotnet/ikvm-bin/ChangeLog b/dev-dotnet/ikvm-bin/ChangeLog
index b87c7f9455fd..7dcb5fc85929 100644
--- a/dev-dotnet/ikvm-bin/ChangeLog
+++ b/dev-dotnet/ikvm-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/ikvm-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm-bin/ChangeLog,v 1.4 2007/02/21 23:09:49 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm-bin/ChangeLog,v 1.5 2007/06/27 02:02:24 jurek Exp $
+
+*ikvm-bin-0.34.0.2 (27 Jun 2007)
+
+ 27 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> +files/ikvm.pc.in,
+ +ikvm-bin-0.34.0.2.ebuild:
+ Version bump
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-dotnet/ikvm-bin/files/digest-ikvm-bin-0.34.0.2 b/dev-dotnet/ikvm-bin/files/digest-ikvm-bin-0.34.0.2
new file mode 100644
index 000000000000..60ec6e36a810
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/files/digest-ikvm-bin-0.34.0.2
@@ -0,0 +1,3 @@
+MD5 bdd2e0b30b24325cdb39f5dd75bdc09c ikvmbin-0.34.0.2.zip 4760345
+RMD160 26fca87617e825b304d44e872f69e3b7bcdb66c9 ikvmbin-0.34.0.2.zip 4760345
+SHA256 720c65f41daf1b859cfabcc063d2b0bc070f8798aae1688f49c60807e4f8b3d7 ikvmbin-0.34.0.2.zip 4760345
diff --git a/dev-dotnet/ikvm-bin/files/ikvm.pc.in b/dev-dotnet/ikvm-bin/files/ikvm.pc.in
new file mode 100644
index 000000000000..3fdd3b5e9806
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/files/ikvm.pc.in
@@ -0,0 +1,9 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/@LIBDIR@
+
+
+Name: IKVM.NET
+Description: An implementation of Java for Mono and the Microsoft .NET Framework.
+Version: @VERSION@
+Libs: -r:${libdir}/ikvm/IKVM.Runtime.dll -r:${libdir}/ikvm/IKVM.GNU.Classpath.dll
diff --git a/dev-dotnet/ikvm-bin/ikvm-bin-0.34.0.2.ebuild b/dev-dotnet/ikvm-bin/ikvm-bin-0.34.0.2.ebuild
new file mode 100644
index 000000000000..1983b9aa7adf
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/ikvm-bin-0.34.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm-bin/ikvm-bin-0.34.0.2.ebuild,v 1.1 2007/06/27 02:02:24 jurek Exp $
+
+inherit eutils mono multilib
+
+MY_P=${P/-bin/}
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Java VM for .NET"
+HOMEPAGE="http://www.ikvm.net/"
+SRC_URI="http://www.go-mono.com/sources/${MY_PN}/${MY_PN}bin-${PV}.zip"
+
+LICENSE="as-is"
+
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.1
+ !dev-dotnet/ikvm
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/${MY_PN}
+ doins bin/*
+
+ for exe in ikvm ikvmc ikvmstub;
+ do
+ make_wrapper ${exe} "mono /usr/$(get_libdir)/${MY_PN}/${exe}.exe"
+ done
+
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ ${FILESDIR}/${MY_PN}.pc.in > ${D}/usr/$(get_libdir)/pkgconfig/${MY_PN}.pc
+}