summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-08-06 00:47:53 +0000
committerPeter Johanson <latexer@gentoo.org>2004-08-06 00:47:53 +0000
commitbcbbc38d7429d7f7fb1a3bdcecf535f65e282cfc (patch)
treef1aa8f02a1a44d9adc10af5726d62dbde2697903 /dev-dotnet/mono
parentnew sqlite ebuild slot (Manifest recommit) (diff)
downloadgentoo-2-bcbbc38d7429d7f7fb1a3bdcecf535f65e282cfc.tar.gz
gentoo-2-bcbbc38d7429d7f7fb1a3bdcecf535f65e282cfc.tar.bz2
gentoo-2-bcbbc38d7429d7f7fb1a3bdcecf535f65e282cfc.zip
Bump. Small bugfix release.
Diffstat (limited to 'dev-dotnet/mono')
-rw-r--r--dev-dotnet/mono/ChangeLog7
-rw-r--r--dev-dotnet/mono/Manifest2
-rw-r--r--dev-dotnet/mono/files/digest-mono-1.0.11
-rw-r--r--dev-dotnet/mono/mono-1.0.1.ebuild61
4 files changed, 70 insertions, 1 deletions
diff --git a/dev-dotnet/mono/ChangeLog b/dev-dotnet/mono/ChangeLog
index c8c5c32ccb0d..3310adffa7b0 100644
--- a/dev-dotnet/mono/ChangeLog
+++ b/dev-dotnet/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/mono
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.26 2004/07/10 06:05:17 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.27 2004/08/06 00:47:53 latexer Exp $
+
+*mono-1.0.1 (05 Aug 2004)
+
+ 05 Aug 2004; Peter Johanson <latexer@gentoo.org> +mono-1.0.1.ebuild:
+ Bump. New bugfix release. Only minimal changes.
10 Jul 2004; Peter Johanson <latexer@gentoo.org> +files/mono-1.0-segv.diff,
mono-1.0.ebuild:
diff --git a/dev-dotnet/mono/Manifest b/dev-dotnet/mono/Manifest
index b26f9fbb576c..3e6cd5ce4c04 100644
--- a/dev-dotnet/mono/Manifest
+++ b/dev-dotnet/mono/Manifest
@@ -3,6 +3,7 @@ MD5 320ce3e4c19a4e80c41ee9400a39f23c mono-0.30.ebuild 2392
MD5 0569a7578a0082a433223c7dad460a6e mono-0.91.ebuild 1661
MD5 6a866ffdedeca043a6aaf267f8e2cab9 mono-0.30.1.ebuild 2394
MD5 d61de115e7b37b55c71b44b0cb2bee89 mono-0.28.ebuild 2093
+MD5 0fa8354fa11ceb04285aa1eeda6f8fcd mono-1.0.1.ebuild 1476
MD5 38b11c580052bca1c3ab11d14b281b51 mono-0.95.ebuild 1557
MD5 198b7500d7079c1159c29aba0b3e3250 mono-0.97.ebuild 1784
MD5 f694ec86655b731f2d46488f531684f5 mono-0.31.ebuild 2546
@@ -11,6 +12,7 @@ MD5 17c5779bfef6d1e1415ec71550d175ea mono-1.0.ebuild 1656
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
MD5 9f4b4eb6a1555ed574dbdd359cae3070 files/dotnet.conf 573
MD5 f33c78b627cbbc1db2ab5f6cc5299e70 files/dotnet.init 1034
+MD5 7d7ffd8b6b060338e93efa00227516e7 files/digest-mono-1.0.1 64
MD5 33b073ed2746ffc3552b2c68a2215b56 files/digest-mono-0.30.1 127
MD5 43da8709d0752a2ef9f9dfb050a05d9f files/digest-mono-0.28 123
MD5 b1d7d1f8b30cadd81ca257cfb0126f2b files/digest-mono-0.30 123
diff --git a/dev-dotnet/mono/files/digest-mono-1.0.1 b/dev-dotnet/mono/files/digest-mono-1.0.1
new file mode 100644
index 000000000000..45d0222a6f3e
--- /dev/null
+++ b/dev-dotnet/mono/files/digest-mono-1.0.1
@@ -0,0 +1 @@
+MD5 e569c5b5a9153dfe10811c17bfefd884 mono-1.0.1.tar.gz 18245041
diff --git a/dev-dotnet/mono/mono-1.0.1.ebuild b/dev-dotnet/mono/mono-1.0.1.ebuild
new file mode 100644
index 000000000000..887cf8a32770
--- /dev/null
+++ b/dev-dotnet/mono/mono-1.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-1.0.1.ebuild,v 1.1 2004/08/06 00:47:53 latexer Exp $
+
+inherit eutils mono flag-o-matic debug
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 | LGPL-2 | X11"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nptl"
+
+DEPEND="virtual/libc
+ >=dev-libs/glib-2.0
+ >=dev-libs/icu-2.6.1
+ !dev-dotnet/pnet
+ ppc? ( >=sys-devel/gcc-3.2.3-r4 )
+ ppc? ( >=sys-libs/glibc-2.3.3_pre20040420 )"
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_compile() {
+ strip-flags
+
+ local myconf=""
+ if use nptl && have_NPTL
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+
+ econf ${myconf} || die
+ emake -j1 || die "MONO compilation failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+ docinto docs
+ dodoc docs/*
+ docinto libgc
+ dodoc libgc/ChangeLog
+
+ # init script
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dotnet.init dotnet
+ insinto /etc/conf.d ; newins ${FILESDIR}/dotnet.conf dotnet
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you want to avoid typing '<runtime> program.exe'"
+ einfo "you can configure your runtime in /etc/conf.d/dotnet"
+ einfo "Use /etc/init.d/dotnet to register your runtime"
+ echo
+}