summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-25 14:22:25 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-25 14:22:25 +0000
commit3ef8546f9930cd706ea97e6167b2ee536cc5ce74 (patch)
tree8e4890f866565d91aab9892e98ab9e586d152713 /dev-dotnet/notify-sharp
parentmonodoc is a build-time dep. (diff)
downloadgentoo-2-3ef8546f9930cd706ea97e6167b2ee536cc5ce74.tar.gz
gentoo-2-3ef8546f9930cd706ea97e6167b2ee536cc5ce74.tar.bz2
gentoo-2-3ef8546f9930cd706ea97e6167b2ee536cc5ce74.zip
Initial import. Ebuild adapted from the one in ikelos' overlay. Bug 235111.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-dotnet/notify-sharp')
-rw-r--r--dev-dotnet/notify-sharp/ChangeLog11
-rw-r--r--dev-dotnet/notify-sharp/metadata.xml5
-rw-r--r--dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-dotnet/notify-sharp/ChangeLog b/dev-dotnet/notify-sharp/ChangeLog
new file mode 100644
index 000000000000..574d1b14dcf7
--- /dev/null
+++ b/dev-dotnet/notify-sharp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-dotnet/notify-sharp
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/notify-sharp/ChangeLog,v 1.1 2008/11/25 14:22:25 loki_val Exp $
+
+*notify-sharp-0.4.0_pre20080912 (25 Nov 2008)
+
+ 25 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> +metadata.xml,
+ +notify-sharp-0.4.0_pre20080912.ebuild:
+ Initial import. Ebuild adapted from the one in ikelos' overlay. Bug
+ 235111.
+
diff --git a/dev-dotnet/notify-sharp/metadata.xml b/dev-dotnet/notify-sharp/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/dev-dotnet/notify-sharp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild
new file mode 100644
index 000000000000..a7c8fb4b271f
--- /dev/null
+++ b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild,v 1.1 2008/11/25 14:22:25 loki_val Exp $
+
+EAPI=2
+
+inherit autotools mono
+
+MY_P=${PN}-${PV#*_pre}
+
+DESCRIPTION="notify-sharp is a C# client implementation for Desktop Notifications"
+HOMEPAGE="http://www.ndesk.org/NotifySharp"
+SRC_URI="http://cvs.fedora.redhat.com/repo/pkgs/${PN}/${MY_P}.tar.bz2/098f3cde158cf26d3efedbfcc19c70dd/${MY_P}.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-1.1.13
+ >=dev-dotnet/gtk-sharp-2.10.1
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-glib-sharp-0.4"
+DEPEND="${RDEPEND}
+ dev-util/monodoc"
+
+S=${WORKDIR}/${MY_P}
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+