summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2005-11-20 05:12:25 +0000
committerLance Albertson <ramereth@gentoo.org>2005-11-20 05:12:25 +0000
commitfc9e331097d5f4bf59965780b2e58f2bbd191b93 (patch)
tree4a96bb3c5fd60512e76848a24f03c7ce58c602d3 /dev-dotnet/xsp/xsp-1.1.10.ebuild
parentversion bump, stable on x86 (diff)
downloadgentoo-2-fc9e331097d5f4bf59965780b2e58f2bbd191b93.tar.gz
gentoo-2-fc9e331097d5f4bf59965780b2e58f2bbd191b93.tar.bz2
gentoo-2-fc9e331097d5f4bf59965780b2e58f2bbd191b93.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'dev-dotnet/xsp/xsp-1.1.10.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-1.1.10.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-1.1.10.ebuild b/dev-dotnet/xsp/xsp-1.1.10.ebuild
new file mode 100644
index 000000000000..7bbf84b3e9f2
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.1.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.1.10.ebuild,v 1.1 2005/11/20 05:12:25 ramereth Exp $
+
+inherit mono autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.0"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ ${S}/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xsp.initd xsp
+ newexe ${FILESDIR}/mod-mono-server.initd mod-mono-server
+ insinto /etc/conf.d ; newins ${FILESDIR}/xsp.confd xsp
+ newins ${FILESDIR}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}