summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-22 23:10:20 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-22 23:10:20 +0000
commit037ee2a1835eba5f1380660a0f77691e8426d2b9 (patch)
tree86594cfc1587523922f5b7b251c47938ccd50c6c /dev-embedded/libftdi
parentbump (diff)
downloadgentoo-2-037ee2a1835eba5f1380660a0f77691e8426d2b9.tar.gz
gentoo-2-037ee2a1835eba5f1380660a0f77691e8426d2b9.tar.bz2
gentoo-2-037ee2a1835eba5f1380660a0f77691e8426d2b9.zip
Add some live git ebuilds.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/ChangeLog9
-rw-r--r--dev-embedded/libftdi/libftdi-9999.1.0.ebuild57
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild57
3 files changed, 122 insertions, 1 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index 93812ac33e4b..245ee48cd110 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-embedded/libftdi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.50 2010/06/22 20:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.51 2010/06/22 23:10:20 vapier Exp $
+
+*libftdi-9999.1.0 (22 Jun 2010)
+*libftdi-9999 (22 Jun 2010)
+
+ 22 Jun 2010; Mike Frysinger <vapier@gentoo.org> +libftdi-9999.ebuild,
+ +libftdi-9999.1.0.ebuild:
+ Add some live git ebuilds.
22 Jun 2010; Mike Frysinger <vapier@gentoo.org> libftdi-0.17.ebuild:
Stabilize for all.
diff --git a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
new file mode 100644
index 000000000000..61a703a42c04
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.1 2010/06/22 23:10:20 vapier Exp $
+
+EAPI="2"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://developer.intra2net.com/libftdi-1.0"
+ inherit git autotools
+else
+ SRC_URI="http://www.intra2net.com/en/developer/libftdi/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="cxx doc examples python"
+
+RDEPEND="virtual/libusb:0
+ cxx? ( dev-libs/boost )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} == 9999* ]] ; then
+ eautoreconf
+ fi
+
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+}
+
+src_configure() {
+ use doc || export ac_cv_path_DOXYGEN=true
+ econf \
+ $(use_enable cxx libftdipp) \
+ $(use_enable python python-binding)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
new file mode 100644
index 000000000000..638c085e7ad7
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.1 2010/06/22 23:10:20 vapier Exp $
+
+EAPI="2"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://developer.intra2net.com/libftdi"
+ inherit git autotools
+else
+ SRC_URI="http://www.intra2net.com/en/developer/libftdi/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="cxx doc examples python"
+
+RDEPEND="virtual/libusb:0
+ cxx? ( dev-libs/boost )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} == 9999* ]] ; then
+ eautoreconf
+ fi
+
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+}
+
+src_configure() {
+ use doc || export ac_cv_path_DOXYGEN=true
+ econf \
+ $(use_enable cxx libftdipp) \
+ $(use_enable python python-binding)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}