summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-05 15:24:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-05 15:24:14 +0000
commitb2eafc683ee3e4f10ffd9f639f64609be28f74dc (patch)
tree8ae832113441e24c1b242f7bf09e2bb16cf9f6f8 /dev-embedded/pk2cmd
parent keyword ~arm (diff)
downloadgentoo-2-b2eafc683ee3e4f10ffd9f639f64609be28f74dc.tar.gz
gentoo-2-b2eafc683ee3e4f10ffd9f639f64609be28f74dc.tar.bz2
gentoo-2-b2eafc683ee3e4f10ffd9f639f64609be28f74dc.zip
Bump to EAPI5, remove old.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-embedded/pk2cmd')
-rw-r--r--dev-embedded/pk2cmd/ChangeLog9
-rw-r--r--dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild53
-rw-r--r--dev-embedded/pk2cmd/pk2cmd-1.20.ebuild15
3 files changed, 12 insertions, 65 deletions
diff --git a/dev-embedded/pk2cmd/ChangeLog b/dev-embedded/pk2cmd/ChangeLog
index 6126be301f16..08dc08a2c4ea 100644
--- a/dev-embedded/pk2cmd/ChangeLog
+++ b/dev-embedded/pk2cmd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-embedded/pk2cmd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/ChangeLog,v 1.6 2012/05/25 08:01:20 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/ChangeLog,v 1.7 2015/01/05 15:24:14 mrueg Exp $
+
+ 05 Jan 2015; Manuel Rüger <mrueg@gentoo.org> -pk2cmd-1.12.0-r1.ebuild,
+ pk2cmd-1.20.ebuild:
+ Bump to EAPI5, remove old.
25 May 2012; Samuli Suominen <ssuominen@gentoo.org> pk2cmd-1.12.0-r1.ebuild,
pk2cmd-1.20.ebuild:
@@ -33,4 +37,3 @@
19 Sep 2008; Joseph Jezak <josejx@gentoo.org> +metadata.xml,
+pk2cmd-1.12.0.ebuild:
Initial ebuild import.
-
diff --git a/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild b/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild
deleted file mode 100644
index b377eb19ef11..000000000000
--- a/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/pk2cmd-1.12.0-r1.ebuild,v 1.5 2012/05/25 08:01:20 ssuominen Exp $
-
-EAPI=1
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An application for working with the Microchip PicKit2 PIC programmer"
-HOMEPAGE="http://www.microchip.com/pickit2"
-SRC_URI="http://ww1.microchip.com/downloads/en/DeviceDoc/${PN}v${PV}LinuxMacSource.tar.gz"
-
-LICENSE="MicroChip-PK2"
-SLOT="0"
-KEYWORDS="~amd64 ppc ppc64 ~x86"
-IUSE=""
-
-DEPEND="virtual/libusb:0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}v${PV}LinuxMacSource"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Patch adds /usr/share/pk2 to the default search for the device file
- epatch "${FILESDIR}/${PN}-add-share-dir-for-dev-file.patch"
-
- # Fix up the Makefile
- sed -i 's:#TARGET=linux:TARGET=linux:' Makefile
- sed -i 's:DBG=-O2:DBG=:' Makefile
- sed -i 's:^CFLAGS=:CFLAGS+=:' Makefile
- sed -i 's:^LDFLAGS=:LDFLAGS+=:' Makefile
- sed -i 's:^LIBUSB=/usr/local:LIBUSB=/usr:' Makefile
- sed -i "s:^CC=g++::" Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCXX)" || die "emake failed"
-}
-
-src_install() {
- # Copy the device files and PicKit2 OS
- insinto "/usr/share/pk2"
- doins PK2DeviceFile.dat
- doins PK2V023200.hex
- # Install the program
- exeinto /usr/bin
- doexe pk2cmd
- # Install the documentation
- dodoc ReadmeForPK2CMDLinux2-6.txt usbhotplug.txt
-}
diff --git a/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild b/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild
index cd85b0c2878d..c0bcdf868547 100644
--- a/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild
+++ b/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild,v 1.4 2012/05/25 08:01:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild,v 1.5 2015/01/05 15:24:14 mrueg Exp $
-EAPI=1
+EAPI=5
inherit eutils toolchain-funcs
@@ -18,12 +18,9 @@ IUSE=""
DEPEND="virtual/libusb:0"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}v${PV}LinuxMacSource"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S=${WORKDIR}/${PN}v${PV}LinuxMacSource
+src_prepare() {
# Patch adds /usr/share/pk2 to the default search for the device file
epatch "${FILESDIR}/${PN}-add-share-dir-for-dev-file-${PV}.patch"
@@ -37,7 +34,7 @@ src_unpack() {
}
src_compile() {
- emake CC="$(tc-getCXX)" || die "emake failed"
+ emake CC="$(tc-getCXX)"
}
src_install() {