summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-01-07 21:35:20 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-01-07 21:35:20 +0000
commit193b5c65c8bc68dac2085dc297e94fabc09bcdaa (patch)
treec1d682e35cdb7590e11edf56728bc6b5eea05c9d /dev-embedded/scratchbox
parentstable ppc, bug 284300 (diff)
downloadgentoo-2-193b5c65c8bc68dac2085dc297e94fabc09bcdaa.tar.gz
gentoo-2-193b5c65c8bc68dac2085dc297e94fabc09bcdaa.tar.bz2
gentoo-2-193b5c65c8bc68dac2085dc297e94fabc09bcdaa.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/scratchbox')
-rw-r--r--dev-embedded/scratchbox/ChangeLog9
-rw-r--r--dev-embedded/scratchbox/scratchbox-1.0.17.ebuild100
2 files changed, 107 insertions, 2 deletions
diff --git a/dev-embedded/scratchbox/ChangeLog b/dev-embedded/scratchbox/ChangeLog
index ebf952237500..89f9233710b2 100644
--- a/dev-embedded/scratchbox/ChangeLog
+++ b/dev-embedded/scratchbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/scratchbox
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.12 2009/11/30 11:05:04 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.13 2010/01/07 21:35:20 ayoy Exp $
+
+*scratchbox-1.0.17 (07 Jan 2010)
+
+ 07 Jan 2010; Dominik Kapusta <ayoy@gentoo.org> +scratchbox-1.0.17.ebuild:
+ Version bump
30 Nov 2009; Diego E. Pettenò <flameeyes@gentoo.org>
scratchbox-1.0.11.ebuild, scratchbox-1.0.16.ebuild:
diff --git a/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild b/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild
new file mode 100644
index 000000000000..f7247df4f7ed
--- /dev/null
+++ b/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild,v 1.1 2010/01/07 21:35:20 ayoy Exp $
+
+inherit eutils
+
+SBOX_GROUP="sbox"
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-core-${PV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-libs-${PV}-i386.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+TARGET_DIR="/opt/scratchbox"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ dodir ${TARGET_DIR}
+ # doins doesn't work with symlinks, getting "file not found" with doins
+ cp -pRP ./* "${D}/${TARGET_DIR}"
+ ln -s opt/scratchbox "${D}/scratchbox"
+
+ # scratchbox service loader
+ newinitd "${FILESDIR}/scratchbox.rc" scratchbox || die "newinitd failed"
+
+ # group already created
+ echo ${SBOX_GROUP} > "${D}/${TARGET_DIR}/.run_me_first_done"
+}
+
+pkg_preinst() {
+ einfo "Creating group sbox"
+ enewgroup "${SBOX_GROUP}"
+}
+
+pkg_postinst() {
+ "${TARGET_DIR}/sbin/sbox_configure" "no" ${SBOX_GROUP}
+
+ elog
+ elog "You can run:"
+ elog "\"emerge --config =${CATEGORY}/${PF}\""
+ elog "to setup scratchbox users"
+ elog
+ elog "For further documentation about how to setup"
+ elog "scratchbox for your development needs have a look at"
+ elog "http://scratchbox.org/documentation/user/scratchbox-1.0/"
+ elog
+ elog "Also note that when you reboot you should run:"
+ elog "/etc/init.d/scratchbox start"
+ elog "before trying to run scratchbox."
+ elog "You can also add it to the default runlevel:"
+ elog "rc-update add scratchbox default"
+ elog
+ elog "Type /opt/scratchbox/login to start scratchbox."
+ elog
+}
+
+pkg_postrm() {
+ elog
+ elog "To remove all traces of scratchbox you will need to remove the file"
+ elog "/etc/init.d/scratchbox. Don't forget to delete the sbox group."
+ elog
+}
+
+pkg_config() {
+ if [ `id -u` != "0" ]; then
+ ewarn "Must be root to run this"
+ die "not root"
+ fi
+
+ mkdir -p "${TARGET_DIR}/users"
+
+ while true; do
+ einfo "Existing users:"
+ einfo $(ls "${TARGET_DIR}/users")
+ echo
+
+ einfo "Create new user (leaf empty to skip): "
+ read newuser
+ case "$newuser" in
+ "")
+ break;
+ ;;
+ *)
+ einfo "Note: users have to be in the '${SBOX_GROUP}' to be able to login into the scratchbox"
+ "${TARGET_DIR}/sbin/sbox_adduser" ${newuser} || die "sbox_adduser failed"
+ ;;
+ esac
+ done
+
+ einfo "Configuration finished. Make sure you run '/etc/init.d/scratchbox start' before logging in."
+}