summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-08-06 18:04:19 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-08-06 18:04:19 +0000
commit559ba9d338313b8927b468b11bd7090e763b4996 (patch)
treef720422251b2be9e40996fe6c73e04574d97041a /dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild
parentx86 stable wrt #233101 (diff)
downloadgentoo-2-559ba9d338313b8927b468b11bd7090e763b4996.tar.gz
gentoo-2-559ba9d338313b8927b468b11bd7090e763b4996.tar.bz2
gentoo-2-559ba9d338313b8927b468b11bd7090e763b4996.zip
Changed the boehmgc USE flag into boehm-gc, see bug #224653.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild')
-rw-r--r--dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild b/dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild
index fab992d26f54..e1b4b6fe1b92 100644
--- a/dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild
+++ b/dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild,v 1.5 2007/02/27 23:29:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/sdcc/sdcc-2.5.0_p20060502.ebuild,v 1.6 2008/08/06 18:04:19 calchan Exp $
inherit eutils
@@ -24,7 +24,7 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix conflicting variable names between Gentoo and sdcc
find ./ -type f -exec sed -i s:PORTDIR:PORTINGDIR:g {} \; || die "sed failed"
@@ -41,11 +41,11 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "Install failed"
+ make DESTDIR="${D}" install || die "Install failed"
dodoc ChangeLog
if use doc ; then
- cp -pPR ${WORKDIR}/doc/* ${D}/usr/share/doc/${PF}/
+ cp -pPR "${WORKDIR}"/doc/* "${D}"/usr/share/doc/${PF}/
fi
- find ${D}/usr/share/doc/${PF}/ -name *.txt -exec gzip -f -9 {} \;
- find ${D}/usr/share/doc/${PF}/ -name */*.txt -exec gzip -f -9 {} \;
+ find "${D}"/usr/share/doc/${PF}/ -name *.txt -exec gzip -f -9 {} \;
+ find "${D}"/usr/share/doc/${PF}/ -name */*.txt -exec gzip -f -9 {} \;
}