summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-02 23:39:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-02 23:39:50 +0000
commit9b828fb91d82b8a41b8d9985cc12a5c60174ffda (patch)
tree6fdd944089fc8a7598f775bc0393f6d7069bd8d3 /dev-embedded/uisp/uisp-20050103.ebuild
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-9b828fb91d82b8a41b8d9985cc12a5c60174ffda.tar.gz
gentoo-2-9b828fb91d82b8a41b8d9985cc12a5c60174ffda.tar.bz2
gentoo-2-9b828fb91d82b8a41b8d9985cc12a5c60174ffda.zip
Removed 2003 version. Patched 2004 version as per bug #74216. Version bump commited
Diffstat (limited to 'dev-embedded/uisp/uisp-20050103.ebuild')
-rw-r--r--dev-embedded/uisp/uisp-20050103.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-embedded/uisp/uisp-20050103.ebuild b/dev-embedded/uisp/uisp-20050103.ebuild
new file mode 100644
index 000000000000..9745abcbc62e
--- /dev/null
+++ b/dev-embedded/uisp/uisp-20050103.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/uisp/uisp-20050103.ebuild,v 1.1 2005/01/02 23:39:50 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for AVR microcontrollers which can interface to many hardware in-system programmers"
+HOMEPAGE="http://savannah.nongnu.org/projects/uisp"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+#SRC_URI="http://savannah.nongnu.org/download/uisp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+DEPEND="sys-apps/gawk
+ sys-devel/gcc
+ >=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.57"
+RDEPEND=""
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}/src
+# epatch ${FILESDIR}/uisp-gcc34.patch
+#}
+
+src_compile() {
+ rm -rf autom4te.cache
+ export WANT_AUTOCONF=2.57 WANT_AUTOMAKE=1.7
+ aclocal || die "aclocal failed"
+ autoheader || die "autoheader failed"
+ autoconf || die "autoconf failed"
+ automake --foreign --add-missing --copy || die "automake failed"
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+ dodoc doc/*
+ prepalldocs
+}