summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-02-21 21:19:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-02-21 21:19:19 +0000
commit1390211119ff961adaa935fa94752fc90d5a72f7 (patch)
tree62b30460259122b46174023fc4d23cb709d4f026 /dev-games/ois/ois-1.3.ebuild
parentmarked x86 per bug 404851 (diff)
downloadgentoo-2-1390211119ff961adaa935fa94752fc90d5a72f7.tar.gz
gentoo-2-1390211119ff961adaa935fa94752fc90d5a72f7.tar.bz2
gentoo-2-1390211119ff961adaa935fa94752fc90d5a72f7.zip
version bump (bug #405179)
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-games/ois/ois-1.3.ebuild')
-rw-r--r--dev-games/ois/ois-1.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-games/ois/ois-1.3.ebuild b/dev-games/ois/ois-1.3.ebuild
new file mode 100644
index 000000000000..d2981ec45c4d
--- /dev/null
+++ b/dev-games/ois/ois-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ois/ois-1.3.ebuild,v 1.1 2012/02/21 21:19:19 mr_bones_ Exp $
+
+EAPI=4
+inherit autotools autotools-utils
+
+MY_P=${PN}-v${PV/./-}
+DESCRIPTION="Object-oriented Input System - A cross-platform C++ input handling library"
+HOMEPAGE="http://www.wreckedgames.com/"
+SRC_URI="mirror://sourceforge/wgois/${MY_P/-/_}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libX11"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
+
+}