summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-04-04 18:46:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-04-04 18:46:46 +0000
commit4b11e00990364888505252102daa44b8b633f6d7 (patch)
tree62fe1dd55d66fe4d18b58ea05981e016c7c05d82 /dev-games/simgear/simgear-0.3.9.ebuild
parentRemoved older versions. (diff)
downloadgentoo-2-4b11e00990364888505252102daa44b8b633f6d7.tar.gz
gentoo-2-4b11e00990364888505252102daa44b8b633f6d7.tar.bz2
gentoo-2-4b11e00990364888505252102daa44b8b633f6d7.zip
gcc-4.1 fix, bug #127404
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'dev-games/simgear/simgear-0.3.9.ebuild')
-rw-r--r--dev-games/simgear/simgear-0.3.9.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-games/simgear/simgear-0.3.9.ebuild b/dev-games/simgear/simgear-0.3.9.ebuild
index ac7bcbfa6019..4f313453cb86 100644
--- a/dev-games/simgear/simgear-0.3.9.ebuild
+++ b/dev-games/simgear/simgear-0.3.9.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-0.3.9.ebuild,v 1.1 2005/12/07 16:28:28 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-0.3.9.ebuild,v 1.2 2006/04/04 18:46:46 tupone Exp $
+
+inherit eutils
MY_P="SimGear-${PV/_/-}"
DESCRIPTION="Development library for simulation games"
@@ -17,6 +19,12 @@ DEPEND=">=media-libs/plib-1.8.4
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+}
+
src_compile() {
econf || die
emake -j1 || die "emake failed"