summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-28 01:52:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-28 01:52:03 +0000
commit79305262c1125bd48bc595f0d46e0464bc64558a (patch)
treeab8011852f92eb98281365ec09d6b485c0726dd9 /dev-games
parentApply patch to fix segfault from bug #75846. Keeping stable keywords. (Manife... (diff)
downloadgentoo-2-79305262c1125bd48bc595f0d46e0464bc64558a.tar.gz
gentoo-2-79305262c1125bd48bc595f0d46e0464bc64558a.tar.bz2
gentoo-2-79305262c1125bd48bc595f0d46e0464bc64558a.zip
Add patch to make GL happy #75702 by Tom Wesley.
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog6
-rw-r--r--dev-games/crystalspace/crystalspace-0.98.4.ebuild10
-rw-r--r--dev-games/crystalspace/files/0.98.4-gl.patch29
3 files changed, 43 insertions, 2 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 209750e0f5d9..8af847bbaacc 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/crystalspace
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.9 2004/12/25 08:00:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.10 2004/12/28 01:52:02 vapier Exp $
+
+ 27 Dec 2004; Mike Frysinger <vapier@gentoo.org> +files/0.98.4-gl.patch,
+ crystalspace-0.98.4.ebuild:
+ Add patch to make GL happy #75702 by Tom Wesley.
*crystalspace-0.98.4 (25 Dec 2004)
diff --git a/dev-games/crystalspace/crystalspace-0.98.4.ebuild b/dev-games/crystalspace/crystalspace-0.98.4.ebuild
index a73ad1ba3013..8b3581672c61 100644
--- a/dev-games/crystalspace/crystalspace-0.98.4.ebuild
+++ b/dev-games/crystalspace/crystalspace-0.98.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.ebuild,v 1.3 2004/12/26 06:42:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.ebuild,v 1.4 2004/12/28 01:52:02 vapier Exp $
+
+inherit eutils
MY_P="cs${PV:2:2}_00${PV:5:1}"
DESCRIPTION="portable 3D Game Development Kit written in C++"
@@ -34,6 +36,12 @@ S="${WORKDIR}/CS"
CRYSTAL_PREFIX="/opt/crystal"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gl.patch #75702
+}
+
src_compile() {
./configure --prefix=${CRYSTAL_PREFIX} || die "configure failed"
jam all || die "compile failed"
diff --git a/dev-games/crystalspace/files/0.98.4-gl.patch b/dev-games/crystalspace/files/0.98.4-gl.patch
new file mode 100644
index 000000000000..20418f00b4ab
--- /dev/null
+++ b/dev-games/crystalspace/files/0.98.4-gl.patch
@@ -0,0 +1,29 @@
+Some GL header files (like nvidia) define GLcharARB/GLhandleARB
+differently ... this pisses off newer gcc's :)
+
+C++ ./out/linuxx86/optimize/plugins/video/renderer/opengl/ogl_g3d.o
+In file included from ./plugins/video/canvas/openglcommon/glstates.h:29,
+ from plugins/video/renderer/opengl/ogl_g3dcom.h:49,
+ from plugins/video/renderer/opengl/ogl_g3d.h:29,
+ from plugins/video/renderer/opengl/ogl_g3d.cpp:33:
+./plugins/video/canvas/openglcommon/glextmanager.h:110: error: conflicting declaration 'typedef unsigned int GLhandleARB'
+/usr/X11R6/include/GL/glext.h:2268: error: 'GLhandleARB' has a previous declaration as `typedef long unsigned int GLhandleARB'
+./plugins/video/canvas/openglcommon/glextmanager.h:110: error: declaration of `typedef unsigned int GLhandleARB'
+/usr/X11R6/include/GL/glext.h:2268: error: conflicts with previous declaration `typedef long unsigned int GLhandleARB'
+./plugins/video/canvas/openglcommon/glextmanager.h:110: error: declaration of `typedef unsigned int GLhandleARB'
+/usr/X11R6/include/GL/glext.h:2268: error: conflicts with previous declaration `typedef long unsigned int GLhandleARB'
+
+Patch by Tom Wesley resolves this
+http://bugs.gentoo.org/show_bug.cgi?id=75702
+
+--- CS/plugins/video/canvas/openglcommon/glextmanager.h.orig 2004-12-27 19:38:02.640064016 -0500
++++ CS/plugins/video/canvas/openglcommon/glextmanager.h 2004-12-27 19:38:08.371192752 -0500
+@@ -106,8 +106,6 @@
+ /*
+ Appear in the ARB_shader_objects ext spec.
+ */
+-typedef char GLcharARB;
+-typedef unsigned int GLhandleARB;
+
+ #include "iutil/cmdline.h"
+ #include "iutil/objreg.h"