summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 09:59:32 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 09:59:32 +0000
commit7918e58774c39ac23efe1400ea71da7b6750e394 (patch)
tree73584d6f23a5a372edcc612a693413f8ae748b74 /dev-haskell/aeson
parentBump test-framework-quickcheck2 to 0.3.0.2 (diff)
downloadgentoo-2-7918e58774c39ac23efe1400ea71da7b6750e394.tar.gz
gentoo-2-7918e58774c39ac23efe1400ea71da7b6750e394.tar.bz2
gentoo-2-7918e58774c39ac23efe1400ea71da7b6750e394.zip
Bump aeson to 0.6.2.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/aeson')
-rw-r--r--dev-haskell/aeson/ChangeLog7
-rw-r--r--dev-haskell/aeson/aeson-0.6.2.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-haskell/aeson/ChangeLog b/dev-haskell/aeson/ChangeLog
index 24c7e41d5834..c8b0719c1dfd 100644
--- a/dev-haskell/aeson/ChangeLog
+++ b/dev-haskell/aeson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/aeson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson/ChangeLog,v 1.3 2013/09/13 09:00:30 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson/ChangeLog,v 1.4 2013/10/19 09:59:32 gienah Exp $
+
+*aeson-0.6.2.1 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +aeson-0.6.2.1.ebuild:
+ Bump aeson to 0.6.2.1
*aeson-0.6.2.0-r1 (13 Sep 2013)
diff --git a/dev-haskell/aeson/aeson-0.6.2.1.ebuild b/dev-haskell/aeson/aeson-0.6.2.1.ebuild
new file mode 100644
index 000000000000..ef0f42a09ea2
--- /dev/null
+++ b/dev-haskell/aeson/aeson-0.6.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson/aeson-0.6.2.1.ebuild,v 1.1 2013/10/19 09:59:32 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast JSON parsing and encoding"
+HOMEPAGE="https://github.com/bos/aeson"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="developer"
+
+RDEPEND=">=dev-haskell/attoparsec-0.8.6.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ dev-haskell/deepseq:=[profile?]
+ >=dev-haskell/hashable-1.1.2.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/text-0.11.1.0:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag developer developer)
+}