summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:37:39 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:37:39 +0000
commitda5ed6d514d3120d7a616ae215330ae5a63d570d (patch)
tree032b72e69ca095c957ff6be417cc433215e23625 /dev-haskell/basic-prelude
parentdev-haskell/readargs: initial layout (diff)
downloadgentoo-2-da5ed6d514d3120d7a616ae215330ae5a63d570d.tar.gz
gentoo-2-da5ed6d514d3120d7a616ae215330ae5a63d570d.tar.bz2
gentoo-2-da5ed6d514d3120d7a616ae215330ae5a63d570d.zip
dev-haskell/basic-prelude: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/basic-prelude')
-rw-r--r--dev-haskell/basic-prelude/ChangeLog9
-rw-r--r--dev-haskell/basic-prelude/basic-prelude-0.3.5.0.ebuild31
-rw-r--r--dev-haskell/basic-prelude/metadata.xml23
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/basic-prelude/ChangeLog b/dev-haskell/basic-prelude/ChangeLog
new file mode 100644
index 000000000000..ba374c3768cd
--- /dev/null
+++ b/dev-haskell/basic-prelude/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/basic-prelude
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/basic-prelude/ChangeLog,v 1.1 2013/08/26 12:37:39 qnikst Exp $
+
+*basic-prelude-0.3.5.0 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org>
+ +basic-prelude-0.3.5.0.ebuild, +metadata.xml:
+ dev-haskell/basic-prelude: initial layout
diff --git a/dev-haskell/basic-prelude/basic-prelude-0.3.5.0.ebuild b/dev-haskell/basic-prelude/basic-prelude-0.3.5.0.ebuild
new file mode 100644
index 000000000000..fde099f11103
--- /dev/null
+++ b/dev-haskell/basic-prelude/basic-prelude-0.3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/basic-prelude/basic-prelude-0.3.5.0.ebuild,v 1.1 2013/08/26 12:37:39 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An enhanced core prelude; a common foundation for alternate preludes."
+HOMEPAGE="https://github.com/snoyberg/basic-prelude"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hashable:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ =dev-haskell/readargs-1.2*:=[profile?]
+ =dev-haskell/system-filepath-0.4*:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/basic-prelude/metadata.xml b/dev-haskell/basic-prelude/metadata.xml
new file mode 100644
index 000000000000..944fd182f6ca
--- /dev/null
+++ b/dev-haskell/basic-prelude/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ The premise of @basic-prelude@ is that there are a lot of very commonly desired features missing from the standard @Prelude@, such as commonly used operators (@\&lt;$\&gt;@ and @&gt;=&gt;@, for instance) and imports for common datatypes (e.g., @ByteString@ and @Vector@). At the same time, there are lots of other components which are more debatable, such as providing polymorphic versions of common functions.
+
+ So @basic-prelude@ is intended to give a common foundation for a number of alternate preludes. The package provides two modules: @CorePrelude@ provides the common ground for other preludes to build on top of, while @BasicPrelude@ exports @CorePrelude@ together with commonly used list functions to provide a drop-in replacement for the standard @Prelude@.
+
+ Users wishing to have an improved @Prelude@ can use @BasicPrelude@. Developers wishing to create a new prelude should use @CorePrelude@.
+
+ Release history:
+
+ [0.3] Moved a number of exports from @BasicPrelude@ to @CorePrelude@ and vice-versa.
+
+ [0.2] Renamed @BasicPrelude@ to @CorePrelude@ and added a new @BasicPrelude@ module provided a full-featured @Prelude@ alternative. Also added a number of new exports.
+
+ [0.1] Initial version, code taken from @classy-prelude@ with a few minor tweaks.
+ </longdescription>
+</pkgmetadata>