summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-06-05 13:24:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-06-05 13:24:17 +0000
commit5797decf2a0a0b1972fcb8a352b442808709e0d2 (patch)
treef7e92b772127465bd58859f07e103afa149a7afc /dev-haskell/cabal/cabal-1.6.0.3.ebuild
parentalpha/ia64/sh/sparc stable wrt #368281 (diff)
downloadgentoo-2-5797decf2a0a0b1972fcb8a352b442808709e0d2.tar.gz
gentoo-2-5797decf2a0a0b1972fcb8a352b442808709e0d2.tar.bz2
gentoo-2-5797decf2a0a0b1972fcb8a352b442808709e0d2.zip
Removed old.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/cabal/cabal-1.6.0.3.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-1.6.0.3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-haskell/cabal/cabal-1.6.0.3.ebuild b/dev-haskell/cabal/cabal-1.6.0.3.ebuild
deleted file mode 100644
index 92db3ba52b51..000000000000
--- a/dev-haskell/cabal/cabal-1.6.0.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.6.0.3.ebuild,v 1.10 2010/07/01 19:20:29 jer Exp $
-
-CABAL_FEATURES="bootstrap lib profile"
-inherit haskell-cabal eutils
-
-MY_PN="Cabal"
-MY_P="${MY_PN}-${PV}"
-
-# Resolve cyclic dep between filepath and Cabal by using a private copy of
-# filepath when building Cabal.
-FP_PN=filepath
-FP_PV=1.1.0.1
-FP_P=${FP_PN}-${FP_PV}
-
-DESCRIPTION="A framework for packaging Haskell software"
-HOMEPAGE="http://www.haskell.org/cabal/"
-SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz
- http://hackage.haskell.org/packages/archive/${FP_PN}/${FP_PV}/${FP_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="doc"
-
-DEPEND=">=dev-lang/ghc-6.4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-CABAL_CORE_LIB_GHC_PV="6.10.2 6.10.3 6.10.4"
-
-src_unpack() {
- unpack ${A}
-
- # We're using the private copy of filepath:
- sed -i -e 's/Build-Depends: filepath >= 1 && < 1.2//' \
- -e '/Other-Modules:/a \
- System.FilePath System.FilePath.Posix System.FilePath.Windows' \
- "${S}/Cabal.cabal"
- # Note: do not replace spaces with tabs on the line above, it'll break
- # things. You'll just have to put up with the repoman warning.
-
- echo " Hs-Source-Dirs: ., ../${FP_P}" >> "${S}/Cabal.cabal"
-}
-
-src_compile() {
- if ! cabal-is-dummy-lib; then
- einfo "Bootstrapping Cabal..."
- $(ghc-getghc) -i -i. -i"${WORKDIR}/${FP_P}" -cpp --make Setup.hs \
- -o setup || die "compiling Setup.hs failed"
- cabal-configure
- cabal-build
- fi
-}