summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-03-17 14:31:56 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-03-17 14:31:56 +0000
commit2f1b36573f1148b25a17cae5587cac7bf54b63da (patch)
treea7ab3c1db45a95943c6896e77d2e3fbfb095503b /dev-haskell/cgi/cgi-2006.9.6.ebuild
parentStable on ppc wrt bug 171052 (diff)
downloadgentoo-2-2f1b36573f1148b25a17cae5587cac7bf54b63da.tar.gz
gentoo-2-2f1b36573f1148b25a17cae5587cac7bf54b63da.tar.bz2
gentoo-2-2f1b36573f1148b25a17cae5587cac7bf54b63da.zip
Add modular lib to ghc 6.6. See bug 151012
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-haskell/cgi/cgi-2006.9.6.ebuild')
-rw-r--r--dev-haskell/cgi/cgi-2006.9.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-haskell/cgi/cgi-2006.9.6.ebuild b/dev-haskell/cgi/cgi-2006.9.6.ebuild
new file mode 100644
index 000000000000..60db7cd4221f
--- /dev/null
+++ b/dev-haskell/cgi/cgi-2006.9.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/cgi-2006.9.6.ebuild,v 1.1 2007/03/17 14:31:56 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+GHC_PV=6.6
+
+DESCRIPTION="A haskell library for writing CGI programs"
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://www.haskell.org/ghc/dist/${GHC_PV}/ghc-${GHC_PV}-src-extralibs.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.6
+ >=dev-haskell/mtl-1.0
+ >=dev-haskell/xhtml-2006.9.13
+ >=dev-haskell/network-2.0"
+
+S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+