summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2015-01-29 20:36:23 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2015-01-29 20:36:23 +0000
commit3d58447b3106885f4fca852e71ff5212ca3beb40 (patch)
tree1dfdebd837a6bee4ae4ad7a5525983899a760c68 /dev-haskell/chell
parentversion bump (diff)
downloadgentoo-2-3d58447b3106885f4fca852e71ff5212ca3beb40.tar.gz
gentoo-2-3d58447b3106885f4fca852e71ff5212ca3beb40.tar.bz2
gentoo-2-3d58447b3106885f4fca852e71ff5212ca3beb40.zip
dev-haskell/chell: update
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 76512BBA09DD3D53)
Diffstat (limited to 'dev-haskell/chell')
-rw-r--r--dev-haskell/chell/ChangeLog8
-rw-r--r--dev-haskell/chell/chell-0.4.0.1.ebuild (renamed from dev-haskell/chell/chell-0.4.ebuild)12
-rw-r--r--dev-haskell/chell/files/chell-0.4-ghc-7.10.patch20
3 files changed, 12 insertions, 28 deletions
diff --git a/dev-haskell/chell/ChangeLog b/dev-haskell/chell/ChangeLog
index 2f01c4a9b9ed..848b133b55e7 100644
--- a/dev-haskell/chell/ChangeLog
+++ b/dev-haskell/chell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/chell
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chell/ChangeLog,v 1.4 2015/01/02 03:27:03 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chell/ChangeLog,v 1.5 2015/01/29 20:36:23 qnikst Exp $
+
+*chell-0.4.0.1 (29 Jan 2015)
+
+ 29 Jan 2015; Alexander Vershilov <qnikst@gentoo.org> +chell-0.4.0.1.ebuild,
+ -chell-0.4.ebuild, -files/chell-0.4-ghc-7.10.patch:
+ dev-haskell/chell: update
02 Jan 2015; Mark Wright <gienah@gentoo.org> +files/chell-0.4-ghc-7.10.patch,
chell-0.4.ebuild:
diff --git a/dev-haskell/chell/chell-0.4.ebuild b/dev-haskell/chell/chell-0.4.0.1.ebuild
index 6fec278d86d2..8467a40eac8f 100644
--- a/dev-haskell/chell/chell-0.4.ebuild
+++ b/dev-haskell/chell/chell-0.4.0.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chell/chell-0.4.ebuild,v 1.3 2015/01/02 03:27:03 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chell/chell-0.4.0.1.ebuild,v 1.1 2015/01/29 20:36:23 qnikst Exp $
EAPI=5
-# ebuild generated by hackport 0.3.6.9999
+# ebuild generated by hackport 0.4.4.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit base haskell-cabal
+inherit haskell-cabal
DESCRIPTION="A simple and intuitive library for automated testing"
HOMEPAGE="https://john-millikin.com/software/chell/"
@@ -23,15 +23,13 @@ RDEPEND=">=dev-haskell/options-1.0:=[profile?] <dev-haskell/options-2.0:=[profil
>=dev-haskell/random-1.0:=[profile?]
dev-haskell/text:=[profile?]
>=dev-haskell/transformers-0.2:=[profile?]
- >=dev-lang/ghc-6.10.4:=
+ >=dev-lang/ghc-7.4.1:=
color-output? ( >=dev-haskell/ansi-terminal-0.5:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6.0.3
+ >=dev-haskell/cabal-1.6
"
-PATCHES=("${FILESDIR}/${PN}-0.4-ghc-7.10.patch")
-
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag color-output color-output)
diff --git a/dev-haskell/chell/files/chell-0.4-ghc-7.10.patch b/dev-haskell/chell/files/chell-0.4-ghc-7.10.patch
deleted file mode 100644
index 831cdcf3b6d1..000000000000
--- a/dev-haskell/chell/files/chell-0.4-ghc-7.10.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- chell-0.4-orig/lib/Test/Chell.hs 2014-05-19 03:42:17.000000000 +1000
-+++ chell-0.4/lib/Test/Chell.hs 2015-01-02 14:19:11.555163417 +1100
-@@ -1,6 +1,7 @@
- {-# LANGUAGE TemplateHaskell #-}
- {-# LANGUAGE TypeSynonymInstances #-}
- {-# LANGUAGE FlexibleInstances #-}
-+{-# LANGUAGE CPP #-}
-
- -- | Chell is a simple and intuitive library for automated testing. It natively
- -- supports assertion-based testing, and can use companion libraries
-@@ -118,6 +119,9 @@
- , testOptionTimeout
- ) where
-
-+#if MIN_VERSION_base(4,8,0)
-+import Prelude hiding(pure)
-+#endif
- import qualified Control.Applicative
- import qualified Control.Exception
- import Control.Exception (Exception)