summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-06-12 19:52:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-06-12 19:52:57 +0000
commit848e4706dd38ce31ea4edd85c954b63d84c063ec (patch)
treec012e1b55bd989a71e95fa71cb29182abd161ae7 /dev-haskell/hdbc-sqlite
parentVersion bump. Requested by Christopher Howard (bug #367211). Removed old vers... (diff)
downloadgentoo-2-848e4706dd38ce31ea4edd85c954b63d84c063ec.tar.gz
gentoo-2-848e4706dd38ce31ea4edd85c954b63d84c063ec.tar.bz2
gentoo-2-848e4706dd38ce31ea4edd85c954b63d84c063ec.zip
Version bump. Requested by Christopher Howard (bug #367211). Removed old versions.
(Portage version: 2.1.10.1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hdbc-sqlite')
-rw-r--r--dev-haskell/hdbc-sqlite/ChangeLog13
-rw-r--r--dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h28
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild23
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.1.0.ebuild31
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild46
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.0.0.ebuild54
6 files changed, 65 insertions, 130 deletions
diff --git a/dev-haskell/hdbc-sqlite/ChangeLog b/dev-haskell/hdbc-sqlite/ChangeLog
index 9ed1e219eaa8..282894b1fc25 100644
--- a/dev-haskell/hdbc-sqlite/ChangeLog
+++ b/dev-haskell/hdbc-sqlite/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/hdbc-sqlite
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.12 2010/07/11 21:36:50 slyfox Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.13 2011/06/12 19:52:57 slyfox Exp $
+
+*hdbc-sqlite-2.3.0.0 (12 Jun 2011)
+
+ 12 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ -files/hdbc-sqlite3-helper.h, -hdbc-sqlite-1.0.0.0.ebuild,
+ -hdbc-sqlite-1.0.1.0.ebuild, -hdbc-sqlite-1.1.3.0.ebuild,
+ +hdbc-sqlite-2.3.0.0.ebuild:
+ Version bump. Requested by Christopher Howard (bug #367211). Removed old
+ versions.
11 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org>
hdbc-sqlite-1.1.3.0.ebuild:
diff --git a/dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h b/dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h
deleted file mode 100644
index 4bd230b85b4a..000000000000
--- a/dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h
+++ /dev/null
@@ -1,28 +0,0 @@
-#include <sqlite3.h>
-
-extern int sqlite3_bind_text2(sqlite3_stmt* a, int b, const char *c, int d);
-
-/* Clever trick: the obj is the first element in the struct, so the pointer
- to the struct is the same as the pointer to the obj. */
-
-typedef struct TAG_finalizeonce {
- void *encapobj;
- int refcount;
- int isfinalized;
- struct TAG_finalizeonce *parent;
-} finalizeonce;
-
-
-extern int sqlite3_open2(const char *filename, finalizeonce **ppo);
-extern int sqlite3_close_app(finalizeonce *ppdb);
-extern void sqlite3_close_finalizer(finalizeonce *ppdb);
-extern void sqlite3_conditional_finalizer(finalizeonce *ppdb);
-
-extern void sqlite3_busy_timeout2(finalizeonce *ppdb, int ms);
-extern int sqlite3_prepare2(finalizeonce *fdb, const char *zSql,
- int nBytes, finalizeonce **ppo,
- const char **pzTail);
-extern int sqlite3_finalize_app(finalizeonce *ppst);
-extern void sqlite3_finalize_finalizer(finalizeonce *ppst);
-
-
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
deleted file mode 100644
index 402bbc8bef79..000000000000
--- a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild,v 1.2 2007/10/31 13:01:36 dcoutts Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal versionator
-
-DESCRIPTION="Sqlite v3 database driver for HDBC"
-HOMEPAGE="http://quux.org/devel/hdbc/"
-SRC_URI="http://quux.org/devel/hdbc/${PN}3_${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- ~dev-haskell/hdbc-${hdbc_PV}
- >=dev-db/sqlite-3.2"
-
-S="${WORKDIR}/${PN}3"
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.1.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.1.0.ebuild
deleted file mode 100644
index b6e4ccdd500f..000000000000
--- a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.1.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.1.0.ebuild,v 1.2 2007/10/31 13:01:36 dcoutts Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit base haskell-cabal versionator
-
-DESCRIPTION="Sqlite v3 database driver for HDBC"
-HOMEPAGE="http://quux.org/devel/hdbc/"
-SRC_URI="http://quux.org/devel/hdbc/${PN}3_${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- ~dev-haskell/hdbc-${hdbc_PV}
- >=dev-db/sqlite-3.2"
-
-S="${WORKDIR}/${PN}3"
-
-src_unpack() {
- base_src_unpack
-
- # Fix haddock markup
- sed -i -e 's|execute/fetchrow|execute\\/fetchrow|' \
- "${S}/Database/HDBC/Sqlite3/Statement.hsc"
-}
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild
deleted file mode 100644
index 3b9d8ea1b315..000000000000
--- a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild,v 1.3 2010/07/24 18:18:43 slyfox Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal versionator
-
-MY_PN=HDBC-sqlite3
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Sqlite v3 database driver for HDBC"
-HOMEPAGE="http://software.complete.org/hdbc-sqlite3"
-SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- dev-haskell/mtl
- =dev-haskell/hdbc-${hdbc_PV}*
- >=dev-db/sqlite-3.2"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
-
- cp "${FILESDIR}/hdbc-sqlite3-helper.h" "${S}/"
- sed -i -e 's/GHC-Options: -O2 -Wall/GHC-Options: -fvia-C/' \
- -e '/^Extensions:/a \
- , ForeignFunctionInterface, EmptyDataDecls' \
- "${S}/${MY_PN}.cabal"
-
- if version_is_at_least "6.8" "$(ghc-version)"; then
- sed -i -e '/Build-Depends:/a \
- , bytestring' \
- "${S}/${MY_PN}.cabal"
- echo "GHC-Options: -XPatternSignatures" >> "${S}/${MY_PN}.cabal"
- fi
-}
-
-CABAL_CONFIGURE_FLAGS="--constraint=base<4"
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.0.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.0.0.ebuild
new file mode 100644
index 000000000000..823a936fba47
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.0.0.ebuild,v 1.1 2011/06/12 19:52:57 slyfox Exp $
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-sqlite3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sqlite v3 driver for HDBC"
+HOMEPAGE="http://software.complete.org/hdbc-sqlite3"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # not all files are bundled
+
+RDEPEND=">=dev-lang/ghc-6.10
+ >=dev-haskell/hdbc-2.2
+ dev-haskell/mtl
+ dev-haskell/utf8-string
+ >=dev-db/sqlite-3.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+ test? ( dev-haskell/convertible
+ dev-haskell/hunit
+ dev-haskell/testpack
+ dev-haskell/time
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}