summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 14:50:23 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 14:50:23 +0000
commite867328ea736d5e1f7182020305298aedd39f0d5 (patch)
tree1893cf672a92c6b1585ff0784dc95422ea495318 /dev-haskell/highlighting-kate
parentBump mime-types to 0.1.0.4 (diff)
downloadgentoo-2-e867328ea736d5e1f7182020305298aedd39f0d5.tar.gz
gentoo-2-e867328ea736d5e1f7182020305298aedd39f0d5.tar.bz2
gentoo-2-e867328ea736d5e1f7182020305298aedd39f0d5.zip
Bump highlighting-kate to 0.5.8.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/highlighting-kate')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog8
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.8.3.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index 7ac4594199ca..417145684c4a 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.16 2014/05/10 12:11:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.17 2014/07/02 14:50:23 gienah Exp $
+
+*highlighting-kate-0.5.8.3 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org>
+ +highlighting-kate-0.5.8.3.ebuild:
+ Bump highlighting-kate to 0.5.8.3
*highlighting-kate-0.5.7 (10 May 2014)
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.8.3.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.8.3.ebuild
new file mode 100644
index 000000000000..d2a5db75036b
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.8.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.8.3.ebuild,v 1.1 2014/07/02 14:50:23 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
+ !pcre-light? ( >=dev-haskell/regex-pcre-builtin-0.94.4.8.8.35:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ # SpecConstr OOMs ghc
+ [[ $(ghc-version) == 7.8.* ]] && replace-hcflags -O[2-9] -O1
+
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}