summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 12:53:24 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 12:53:24 +0000
commitbe0eb92eb37e095bf934f66e87e4b1238f9506b6 (patch)
treebb1d1b4da4425931293102ddc9ecb7fd86397626 /dev-haskell/network-conduit
parentBump mono-traversable to 0.4.0.1 (diff)
downloadgentoo-2-be0eb92eb37e095bf934f66e87e4b1238f9506b6.tar.gz
gentoo-2-be0eb92eb37e095bf934f66e87e4b1238f9506b6.tar.bz2
gentoo-2-be0eb92eb37e095bf934f66e87e4b1238f9506b6.zip
Bump network-conduit to 1.0.2.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/network-conduit')
-rw-r--r--dev-haskell/network-conduit/ChangeLog9
-rw-r--r--dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-haskell/network-conduit/ChangeLog b/dev-haskell/network-conduit/ChangeLog
index aa79be95cca4..a132314f662d 100644
--- a/dev-haskell/network-conduit/ChangeLog
+++ b/dev-haskell/network-conduit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/network-conduit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network-conduit/ChangeLog,v 1.5 2013/11/24 19:39:50 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network-conduit/ChangeLog,v 1.6 2014/03/09 12:53:24 gienah Exp $
+
+*network-conduit-1.0.2.2 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +network-conduit-1.0.2.2.ebuild:
+ Bump network-conduit to 1.0.2.2
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org>
network-conduit-1.0.0-r1.ebuild:
diff --git a/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild b/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild
new file mode 100644
index 000000000000..836f442d6eec
--- /dev/null
+++ b/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild,v 1.1 2014/03/09 12:53:24 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -network-bytestring
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Stream socket data using conduits."
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-network-bytestring
+}