summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-06-20 06:18:46 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-06-20 06:18:46 +0000
commita4102bd6a2a92d9372f49190a02269ad9992aa71 (patch)
treecee45206df1388bb682e0109560335b99c0a5af5 /dev-haskell/recaptcha
parentadd 0.7.1 due to #473858 (diff)
downloadgentoo-2-a4102bd6a2a92d9372f49190a02269ad9992aa71.tar.gz
gentoo-2-a4102bd6a2a92d9372f49190a02269ad9992aa71.tar.bz2
gentoo-2-a4102bd6a2a92d9372f49190a02269ad9992aa71.zip
add recaptcha-0.1 due to #473858
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/recaptcha')
-rw-r--r--dev-haskell/recaptcha/ChangeLog9
-rw-r--r--dev-haskell/recaptcha/metadata.xml14
-rw-r--r--dev-haskell/recaptcha/recaptcha-0.1-r1.ebuild26
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/recaptcha/ChangeLog b/dev-haskell/recaptcha/ChangeLog
new file mode 100644
index 000000000000..2b8d56922be6
--- /dev/null
+++ b/dev-haskell/recaptcha/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/recaptcha
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/recaptcha/ChangeLog,v 1.1 2013/06/20 06:18:46 qnikst Exp $
+
+*recaptcha-0.1-r1 (20 Jun 2013)
+
+ 20 Jun 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +recaptcha-0.1-r1.ebuild:
+ add recaptcha-0.1 due to #473858
diff --git a/dev-haskell/recaptcha/metadata.xml b/dev-haskell/recaptcha/metadata.xml
new file mode 100644
index 000000000000..a691a0ec4809
--- /dev/null
+++ b/dev-haskell/recaptcha/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ reCAPTCHA (http://recaptcha.net/) is a service that provides
+ captchas for preventing automated spam in web applications.
+ recaptcha-hs provides functions for using reCAPTCHA in Haskell
+ web applications.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/recaptcha/recaptcha-0.1-r1.ebuild b/dev-haskell/recaptcha/recaptcha-0.1-r1.ebuild
new file mode 100644
index 000000000000..89048c2f729d
--- /dev/null
+++ b/dev-haskell/recaptcha/recaptcha-0.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/recaptcha/recaptcha-0.1-r1.ebuild,v 1.1 2013/06/20 06:18:46 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Functions for using the reCAPTCHA service in web applications."
+HOMEPAGE="http://github.com/jgm/recaptcha/tree/master"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/http-3001.1.4:=[profile?]
+ >=dev-haskell/network-2.2.0.1:=[profile?]
+ >=dev-haskell/xhtml-3000.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"