summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 05:53:20 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 05:53:20 +0000
commite473fa33026ce5e9980eace08fab47e3e4c7109c (patch)
treefd96e01f5c6e6771c26e94338185ff0453c91249 /dev-haskell/statistics/statistics-0.13.2.1.ebuild
parentBump skein to 1.0.9.2 (diff)
downloadgentoo-2-e473fa33026ce5e9980eace08fab47e3e4c7109c.tar.gz
gentoo-2-e473fa33026ce5e9980eace08fab47e3e4c7109c.tar.bz2
gentoo-2-e473fa33026ce5e9980eace08fab47e3e4c7109c.zip
Bump statistics to 0.13.2.1
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/statistics/statistics-0.13.2.1.ebuild')
-rw-r--r--dev-haskell/statistics/statistics-0.13.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/statistics/statistics-0.13.2.1.ebuild b/dev-haskell/statistics/statistics-0.13.2.1.ebuild
new file mode 100644
index 000000000000..ef32ab1c0eef
--- /dev/null
+++ b/dev-haskell/statistics/statistics-0.13.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/statistics/statistics-0.13.2.1.ebuild,v 1.1 2014/12/14 05:53:20 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library of statistical types, data, and functions"
+HOMEPAGE="https://github.com/bos/statistics"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # likes to fail under a load
+
+RDEPEND=">=dev-haskell/aeson-0.6.0.0:=[profile?]
+ >=dev-haskell/binary-0.5.1.0:=[profile?]
+ dev-haskell/erf:=[profile?]
+ >=dev-haskell/math-functions-0.1.5.2:=[profile?]
+ >=dev-haskell/monad-par-0.3.4:=[profile?]
+ >=dev-haskell/mwc-random-0.13.0.0:=[profile?]
+ >=dev-haskell/primitive-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/vector-algorithms-0.4:=[profile?]
+ >=dev-haskell/vector-binary-instances-0.2.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/ieee754-0.7.3
+ >=dev-haskell/quickcheck-2.7.5
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"