summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 13:55:15 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 13:55:15 +0000
commit1b4f6cd655bbf7833aedf54fe250dba9ad2a4c1b (patch)
treea23b6e7efea2db3450fbeafa7a24bf65968e87e6 /dev-haskell/uuid
parentdrop old ebuilds, EAPI=0 (diff)
downloadgentoo-2-1b4f6cd655bbf7833aedf54fe250dba9ad2a4c1b.tar.gz
gentoo-2-1b4f6cd655bbf7833aedf54fe250dba9ad2a4c1b.tar.bz2
gentoo-2-1b4f6cd655bbf7833aedf54fe250dba9ad2a4c1b.zip
dev-haskell/uuid: add uuid
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/uuid')
-rw-r--r--dev-haskell/uuid/ChangeLog9
-rw-r--r--dev-haskell/uuid/metadata.xml13
-rw-r--r--dev-haskell/uuid/uuid-1.2.13.ebuild40
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/uuid/ChangeLog b/dev-haskell/uuid/ChangeLog
new file mode 100644
index 000000000000..d89f09715330
--- /dev/null
+++ b/dev-haskell/uuid/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/uuid
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uuid/ChangeLog,v 1.1 2013/08/26 13:55:15 qnikst Exp $
+
+*uuid-1.2.13 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +uuid-1.2.13.ebuild:
+ dev-haskell/uuid: add uuid
diff --git a/dev-haskell/uuid/metadata.xml b/dev-haskell/uuid/metadata.xml
new file mode 100644
index 000000000000..abc1db5fa73b
--- /dev/null
+++ b/dev-haskell/uuid/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This library is useful for creating, comparing, parsing and
+ printing Universally Unique Identifiers.
+ See &lt;http://en.wikipedia.org/wiki/UUID&gt; for the general idea.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/uuid/uuid-1.2.13.ebuild b/dev-haskell/uuid/uuid-1.2.13.ebuild
new file mode 100644
index 000000000000..f26fb5adf2ec
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.2.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uuid/uuid-1.2.13.ebuild,v 1.1 2013/08/26 13:55:15 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="http://projects.haskell.org/uuid/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
+ <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/cryptohash-0.7:=[profile?]
+ <dev-haskell/cryptohash-0.10:=[profile?]
+ >=dev-haskell/maccatcher-1.0:=[profile?]
+ <dev-haskell/maccatcher-2.2:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?]
+ <dev-haskell/random-1.1:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/criterion-0.4
+ <dev-haskell/criterion-0.9
+ >=dev-haskell/deepseq-1.1
+ <dev-haskell/deepseq-1.4
+ =dev-haskell/hunit-1.2*
+ dev-haskell/mersenne-random-pure64
+ >=dev-haskell/quickcheck-2.4
+ <dev-haskell/quickcheck-2.7
+ )"