summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 07:05:35 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 07:05:35 +0000
commit9e6c1f23110532857399967a09273ef55b94c01d (patch)
tree0d97b8a26218cef9d0b3a11280497da34ef28ac6 /dev-haskell/wai-app-static
parentBump wai to 3.0.2 (diff)
downloadgentoo-2-9e6c1f23110532857399967a09273ef55b94c01d.tar.gz
gentoo-2-9e6c1f23110532857399967a09273ef55b94c01d.tar.bz2
gentoo-2-9e6c1f23110532857399967a09273ef55b94c01d.zip
Bump wai-app-static to 3.0.0.3
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/wai-app-static')
-rw-r--r--dev-haskell/wai-app-static/ChangeLog7
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-3.0.0.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-haskell/wai-app-static/ChangeLog b/dev-haskell/wai-app-static/ChangeLog
index 1381d487b18c..8f0f00a87d12 100644
--- a/dev-haskell/wai-app-static/ChangeLog
+++ b/dev-haskell/wai-app-static/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/wai-app-static
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-app-static/ChangeLog,v 1.7 2014/07/25 08:58:24 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-app-static/ChangeLog,v 1.8 2014/12/14 07:05:35 gienah Exp $
+
+*wai-app-static-3.0.0.3 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +wai-app-static-3.0.0.3.ebuild:
+ Bump wai-app-static to 3.0.0.3
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/wai-app-static/wai-app-static-3.0.0.3.ebuild b/dev-haskell/wai-app-static/wai-app-static-3.0.0.3.ebuild
new file mode 100644
index 000000000000..9e26f5f35bc8
--- /dev/null
+++ b/dev-haskell/wai-app-static/wai-app-static-3.0.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-app-static/wai-app-static-3.0.0.3.ebuild,v 1.1 2014/12/14 07:05:35 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="WAI application for static serving"
+HOMEPAGE="http://www.yesodweb.com/book/web-application-interface"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="print"
+
+RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?]
+ dev-haskell/cryptohash-conduit:=[profile?]
+ >=dev-haskell/file-embed-0.0.3.1:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/mime-types-0.1:=[profile?] <dev-haskell/mime-types-0.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.7:=[profile?]
+ >=dev-haskell/system-fileio-0.3:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-haskell/wai-extra-3.0:=[profile?] <dev-haskell/wai-extra-3.1:=[profile?]
+ >=dev-haskell/warp-3.0:=[profile?] <dev-haskell/warp-3.1:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/network )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag print print)
+}