summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 07:09:39 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 07:09:39 +0000
commit7158a3e0249119ad15803c61a38e9b32ce9926b7 (patch)
tree87f96eb4f1a18fb2c4dbb5d37c3517a2daf8a633 /dev-haskell/warp
parentBump wai-logger to 2.2.3 (diff)
downloadgentoo-2-7158a3e0249119ad15803c61a38e9b32ce9926b7.tar.gz
gentoo-2-7158a3e0249119ad15803c61a38e9b32ce9926b7.tar.bz2
gentoo-2-7158a3e0249119ad15803c61a38e9b32ce9926b7.zip
Bump warp to 3.0.4
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/warp')
-rw-r--r--dev-haskell/warp/ChangeLog7
-rw-r--r--dev-haskell/warp/warp-3.0.4.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-haskell/warp/ChangeLog b/dev-haskell/warp/ChangeLog
index 2f56a0d18eb3..f5f8d7426602 100644
--- a/dev-haskell/warp/ChangeLog
+++ b/dev-haskell/warp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/warp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp/ChangeLog,v 1.11 2014/07/25 09:16:35 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp/ChangeLog,v 1.12 2014/12/14 07:09:39 gienah Exp $
+
+*warp-3.0.4 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +warp-3.0.4.ebuild:
+ Bump warp to 3.0.4
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> warp-1.3.9.2.ebuild,
warp-2.0.3.3.ebuild, warp-2.1.0.ebuild, warp-3.0.0.3.ebuild:
diff --git a/dev-haskell/warp/warp-3.0.4.ebuild b/dev-haskell/warp/warp-3.0.4.ebuild
new file mode 100644
index 000000000000..b9ce649c7ad1
--- /dev/null
+++ b/dev-haskell/warp/warp-3.0.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp/warp-3.0.4.ebuild,v 1.1 2014/12/14 07:09:39 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -network-bytestring
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A fast, light-weight web server for WAI applications"
+HOMEPAGE="http://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+allow-sendfilefd warp-debug"
+
+RDEPEND=">=dev-haskell/auto-update-0.1.1:=[profile?] <dev-haskell/auto-update-0.2:=[profile?]
+ >=dev-haskell/blaze-builder-0.3.3:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.8.5:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.2:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ allow-sendfilefd? ( dev-haskell/hashable:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ >=dev-haskell/doctest-0.9.3
+ >=dev-haskell/hspec-1.3
+ dev-haskell/http
+ dev-haskell/hunit
+ >=dev-haskell/lifted-base-0.1
+ dev-haskell/quickcheck
+ >=dev-haskell/transformers-0.2.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag allow-sendfilefd allow-sendfilefd) \
+ --flag=-network-bytestring \
+ $(cabal_flag warp-debug warp-debug)
+}