summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 14:05:07 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 14:05:07 +0000
commit07b8805f762e9d572f841124b4150cdace2defe8 (patch)
tree32f1b46917bf8c5aa870f067419fa6f445c29b04 /dev-haskell
parentFix LICENSE, see README file in tarball. Remove old. Bug 441994. (diff)
downloadgentoo-2-07b8805f762e9d572f841124b4150cdace2defe8.tar.gz
gentoo-2-07b8805f762e9d572f841124b4150cdace2defe8.tar.bz2
gentoo-2-07b8805f762e9d572f841124b4150cdace2defe8.zip
Bump json to 0.7
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/json/ChangeLog7
-rw-r--r--dev-haskell/json/json-0.7.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-haskell/json/ChangeLog b/dev-haskell/json/ChangeLog
index 7891bc671072..5d9da60707a7 100644
--- a/dev-haskell/json/ChangeLog
+++ b/dev-haskell/json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/ChangeLog,v 1.7 2012/11/11 17:56:10 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/ChangeLog,v 1.8 2012/11/18 14:05:07 gienah Exp $
+
+*json-0.7 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org> +json-0.7.ebuild:
+ Bump json to 0.7
11 Nov 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/json-0.4.3-ghc-7.4.patch, json-0.4.3.ebuild, json-0.4.4.ebuild:
diff --git a/dev-haskell/json/json-0.7.ebuild b/dev-haskell/json/json-0.7.ebuild
new file mode 100644
index 000000000000..dc599b119d63
--- /dev/null
+++ b/dev-haskell/json/json-0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/json-0.7.ebuild,v 1.1 2012/11/18 14:05:07 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for serialising Haskell to and from JSON"
+HOMEPAGE="http://hackage.haskell.org/package/json"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+generic +parsec +pretty"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ parsec? ( dev-haskell/parsec:=[profile?] )
+ generic? ( >=dev-haskell/syb-0.3.3:=[profile?] )
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.0"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag generic) \
+ $(cabal_flag parsec) \
+ $(cabal_flag pretty)
+}