summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-03-08 21:04:05 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-03-08 21:04:05 +0000
commit0d1db4e521ae21ec6db21244cec35928b0c05dbd (patch)
tree2eadf6ed84384c9c220ffa803b41962baf39b1ce /dev-haskell
parentadd in *vimrc_file_suffix (diff)
downloadgentoo-2-0d1db4e521ae21ec6db21244cec35928b0c05dbd.tar.gz
gentoo-2-0d1db4e521ae21ec6db21244cec35928b0c05dbd.tar.bz2
gentoo-2-0d1db4e521ae21ec6db21244cec35928b0c05dbd.zip
Adding hsshellscript-2.2.0 version
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hsshellscript/ChangeLog7
-rw-r--r--dev-haskell/hsshellscript/Manifest12
-rw-r--r--dev-haskell/hsshellscript/files/digest-hsshellscript-2.2.01
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.2.0.ebuild45
4 files changed, 54 insertions, 11 deletions
diff --git a/dev-haskell/hsshellscript/ChangeLog b/dev-haskell/hsshellscript/ChangeLog
index 9c203a5c2761..c7a249b6aed4 100644
--- a/dev-haskell/hsshellscript/ChangeLog
+++ b/dev-haskell/hsshellscript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hsshellscript
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.3 2005/03/07 10:56:36 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.4 2005/03/08 21:04:05 araujo Exp $
+
+*hsshellscript-2.2.0 (08 Mar 2005)
+
+ 08 Mar 2005; Luis F. Araujo <araujo@gentoo.org> +hsshellscript-2.2.0.ebuild:
+ New hsshellscript release
07 Mar 2005; Luis F. Araujo <araujo@gentoo.org> :
Removed duplicated ChangeLog entry.
diff --git a/dev-haskell/hsshellscript/Manifest b/dev-haskell/hsshellscript/Manifest
index abc167554bb8..e622e26bbd6e 100644
--- a/dev-haskell/hsshellscript/Manifest
+++ b/dev-haskell/hsshellscript/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 98fa8cd9f06c07d9985e98a9f52512ab ChangeLog 578
MD5 7d6203f46f91795c95ca6a22ee6dff5a hsshellscript-2.1.0.ebuild 1239
MD5 3f6e26f4a44d1b5c6ff6380d989e6af6 metadata.xml 222
+MD5 97dc6ea1743ef769c05e199caf60aeac hsshellscript-2.2.0.ebuild 1014
MD5 29b043a8133ca29f855bd09a4ce05033 files/digest-hsshellscript-2.1.0 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFCLDOSBQBy/eDH5uERAhmSAJ40ZzDhxTrAJmUjCPiuPUz7Dg4IvwCcCnta
-JeZXYCfpBBJvJ5h9zTHZmsM=
-=P5fQ
------END PGP SIGNATURE-----
+MD5 c16f03216f6b47b89224ab176c13aa21 files/digest-hsshellscript-2.2.0 71
diff --git a/dev-haskell/hsshellscript/files/digest-hsshellscript-2.2.0 b/dev-haskell/hsshellscript/files/digest-hsshellscript-2.2.0
new file mode 100644
index 000000000000..45362d83f2fb
--- /dev/null
+++ b/dev-haskell/hsshellscript/files/digest-hsshellscript-2.2.0
@@ -0,0 +1 @@
+MD5 14c07934268fd7722f990cb6c983f57a hsshellscript-2.2.0.tar.gz 162158
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.2.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.2.0.ebuild
new file mode 100644
index 000000000000..eedba51f5498
--- /dev/null
+++ b/dev-haskell/hsshellscript/hsshellscript-2.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.2.0.ebuild,v 1.1 2005/03/08 21:04:05 araujo Exp $
+
+inherit base eutils ghc-package
+
+DESCRIPTION="A Haskell library for UNIX shell scripting tasks"
+HOMEPAGE="http://www.volker-wysk.de/hsshellscript/"
+SRC_URI="http://www.volker-wysk.de/hsshellscript/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.2"
+RDEPEND=""
+
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ sed -i -e "/ghc-pkg/d" Makefile
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ sed -i "s:\${DEST_LIB}:$(ghc-libdir):" \
+ ${S}/lib/hsshellscript.pkg
+ sed -i "s:\${DEST_IMPORTS}:$(ghc-libdir)/imports:" \
+ ${S}/lib/hsshellscript.pkg
+ ghc-setup-pkg ${S}/lib/hsshellscript.pkg
+ make install \
+ DESTDIR="${D}" \
+ DEST_LIB="$(ghc-libdir)" \
+ DEST_IMPORTS="$(ghc-libdir)/imports" \
+ DEST_DOC="/usr/share/doc/${PF}" \
+ || die "make failed"
+ ghc-install-pkg
+ ghc-makeghcilib ${D}/$(ghc-libdir)/libhsshellscript.a
+}