summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 13:43:39 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 13:43:39 +0000
commit39a03e9dbc5cb93110ca7329972561066f57a5a3 (patch)
tree8108ffcb5faf190556f812f323d4e9f32c0b3398 /dev-haskell
parentAdd workaround for gles failure, bug #440148. (diff)
downloadgentoo-2-39a03e9dbc5cb93110ca7329972561066f57a5a3.tar.gz
gentoo-2-39a03e9dbc5cb93110ca7329972561066f57a5a3.tar.bz2
gentoo-2-39a03e9dbc5cb93110ca7329972561066f57a5a3.zip
Bump haskell-platform to 2012.4.0.0
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haskell-platform/ChangeLog9
-rw-r--r--dev-haskell/haskell-platform/haskell-platform-2012.4.0.0.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-haskell/haskell-platform/ChangeLog b/dev-haskell/haskell-platform/ChangeLog
index 7c4fab2724c5..511f468d7740 100644
--- a/dev-haskell/haskell-platform/ChangeLog
+++ b/dev-haskell/haskell-platform/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haskell-platform
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-platform/ChangeLog,v 1.7 2012/06/03 04:40:19 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-platform/ChangeLog,v 1.8 2012/11/18 13:43:39 gienah Exp $
+
+*haskell-platform-2012.4.0.0 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org>
+ +haskell-platform-2012.4.0.0.ebuild:
+ Bump haskell-platform to 2012.4.0.0
*haskell-platform-2011.4.0.0 (03 Jun 2012)
*haskell-platform-2012.2.0.0 (03 Jun 2012)
@@ -39,4 +45,3 @@
10 May 2009; Lennart Kolmodin <kolmodin@gentoo.org> ChangeLog:
Initial version.
-
diff --git a/dev-haskell/haskell-platform/haskell-platform-2012.4.0.0.ebuild b/dev-haskell/haskell-platform/haskell-platform-2012.4.0.0.ebuild
new file mode 100644
index 000000000000..05b70b448dab
--- /dev/null
+++ b/dev-haskell/haskell-platform/haskell-platform-2012.4.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-platform/haskell-platform-2012.4.0.0.ebuild,v 1.1 2012/11/18 13:43:39 gienah Exp $
+
+EAPI=5
+
+DESCRIPTION="The Haskell Platform"
+HOMEPAGE="http://haskell.org/platform"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile X"
+
+RDEPEND=">=dev-haskell/async-2.0.1.3:=[profile?]
+ >=dev-haskell/cgi-3001.1.7.4:=[profile?]
+ >=dev-haskell/fgl-5.4.2.4:=[profile?]
+ >=dev-haskell/haskell-src-1.0.1.5:=[profile?]
+ >=dev-haskell/html-1.0.1.2:=[profile?]
+ >=dev-haskell/http-4000.2.5:=[profile?]
+ >=dev-haskell/hunit-1.2.5.1:=[profile?]
+ >=dev-haskell/mtl-2.1.2:=[profile?]
+ >=dev-haskell/network-2.3.1.0:=[profile?]
+ >=dev-haskell/parallel-3.2.0.3:=[profile?]
+ >=dev-haskell/parsec-3.1.3:=[profile?]
+ >=dev-haskell/primitive-0.5.0.1:=[profile?]
+ >=dev-haskell/quickcheck-2.5.1.1:=[profile?]
+ >=dev-haskell/random-1.0.1.1:=[profile?]
+ >=dev-haskell/regex-base-0.93.2:=[profile?]
+ >=dev-haskell/regex-compat-0.95.1:=[profile?]
+ >=dev-haskell/regex-posix-0.95.2:=[profile?]
+ >=dev-haskell/split-0.2.1.1:=[profile?]
+ >=dev-haskell/stm-2.4:=[profile?]
+ >=dev-haskell/syb-0.3.7:=[profile?]
+ >=dev-haskell/text-0.11.2.3:=[profile?]
+ >=dev-haskell/transformers-0.3.0.0:=[profile?]
+ >=dev-haskell/vector-0.10.0.1:=[profile?]
+ >=dev-haskell/xhtml-3000.2.1:=[profile?]
+ >=dev-haskell/zlib-0.5.4.0:=[profile?]
+ X? (
+ >=dev-haskell/glut-2.1.2.1:=[profile?]
+ >=dev-haskell/opengl-2.2.3.1:=[profile?]
+ )
+ >=dev-lang/ghc-7.4.2:=
+
+ >=dev-haskell/alex-3.0.2
+ >=dev-haskell/cabal-1.14.0
+ >=dev-haskell/happy-1.18.10
+ >=dev-haskell/cabal-install-0.14.0
+ >=dev-haskell/hscolour-1.19
+ >=dev-haskell/haddock-2.10.0"
+
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ if ! use X; then
+ elog "The haskell platform includes the 3D graphics libraries opengl and glut."
+ elog "To install opengl and glut requires the X use flag."
+ fi
+}