summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-02 19:14:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-02 19:14:26 +0000
commit564674cd9b6b7221613bff8ba9fc7a4398c67788 (patch)
treeb0d4fdf16447f9ed3e60aa33b59d0a06b9c975ae /dev-haskell
parentInline 'GTK_MAJ_VER' variable value. (diff)
downloadgentoo-2-564674cd9b6b7221613bff8ba9fc7a4398c67788.tar.gz
gentoo-2-564674cd9b6b7221613bff8ba9fc7a4398c67788.tar.bz2
gentoo-2-564674cd9b6b7221613bff8ba9fc7a4398c67788.zip
Binding to the Gtk+-3 graphical user interface library, a depend for dev-util/bustle-0.5.1.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk3/ChangeLog10
-rw-r--r--dev-haskell/gtk3/Manifest3
-rw-r--r--dev-haskell/gtk3/gtk3-0.13.7.ebuild53
-rw-r--r--dev-haskell/gtk3/metadata.xml14
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-haskell/gtk3/ChangeLog b/dev-haskell/gtk3/ChangeLog
new file mode 100644
index 000000000000..d43f7d32ca62
--- /dev/null
+++ b/dev-haskell/gtk3/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/gtk3
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk3/ChangeLog,v 1.1 2015/08/02 19:14:26 slyfox Exp $
+
+*gtk3-0.13.7 (02 Aug 2015)
+
+ 02 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org> +gtk3-0.13.7.ebuild,
+ +metadata.xml:
+ Binding to the Gtk+-3 graphical user interface library, a depend for dev-
+ util/bustle-0.5.1.
diff --git a/dev-haskell/gtk3/Manifest b/dev-haskell/gtk3/Manifest
new file mode 100644
index 000000000000..1ef5433c2c4e
--- /dev/null
+++ b/dev-haskell/gtk3/Manifest
@@ -0,0 +1,3 @@
+DIST gtk3-0.13.7.tar.gz 673031 SHA256 29bf3dcdb39d01dbbced766ab1d72add67e73e01181668bc3423a71359d94f96 SHA512 c350ae55a7044684e6f2d94592decfcd01d3e96900a468cd417bad52713502c89c328f96cd4ff29647169a76287b8dada9654d46c4dc884c0dab0590ad57762e WHIRLPOOL 2045939ea93c510582a29b8427a607bcf931d8bd7cdaef9a3751fe3fa925bacebfa1ff4980c941470acfecd6b76fb08e99c3934b6b0577ab475bbf26c9e98e40
+EBUILD gtk3-0.13.7.ebuild 1723 SHA256 cfa30779649422665f848264fb426f69496a1c8998d41c51a9b3273c62517596 SHA512 53422bea18c5c5b94473ee35e353f7be5473984ca55e1e48ab2f3ee52b4dd454a828bfe77b11252bb95f560d04885b960fc05d7dd2a15d99f112bbf8e1098db2 WHIRLPOOL 204cab54ff619c174f7b2a48f1da9dfdab7e92e8044777ab3694f28c9875be5ec8ddce1e5404c31253393651b6ddb014fcd7afc8edb5330bb860e2c14e79e90d
+MISC metadata.xml 596 SHA256 268aafb115c85dfcb4b8722114a12249894d7d0bed1f4c308638a032e76e7210 SHA512 7a6e51e06c5a1830d6dd2fe7eb429672ba1eaa82fe14a1a1051d2afd02a2898844bdcf7247564a744d7572b3453adcb17562f2d12ccd5c0ac727abed3ef1941c WHIRLPOOL 27b674508578c19a03c54badd54eee0504b229714eb2296b40c8eabcdd00c43ab842eea68dce1f9a3449ecd23aa8b3acaa76307b3507889009a89923ec9be6c8
diff --git a/dev-haskell/gtk3/gtk3-0.13.7.ebuild b/dev-haskell/gtk3/gtk3-0.13.7.ebuild
new file mode 100644
index 000000000000..3b616268bf68
--- /dev/null
+++ b/dev-haskell/gtk3/gtk3-0.13.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk3/gtk3-0.13.7.ebuild,v 1.1 2015/08/02 19:14:26 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # workaround for module order
+ cabal_chdeps \
+ 'other-modules:' 'exposed-modules:'
+ # fix build with gcc 5.1.0 and later https://github.com/gtk2hs/gtk2hs/issues/104
+ sed -e 's@gccProg, "--cppopts=-E"@gccProg, "--cppopts=-E", "--cppopts=-P"@' \
+ -i Gtk2HsSetup.hs || die
+}
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag examples build-demos) \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-gio) \
+ --flags=-have-quartz-gtk
+}
diff --git a/dev-haskell/gtk3/metadata.xml b/dev-haskell/gtk3/metadata.xml
new file mode 100644
index 000000000000..ee8b0291295b
--- /dev/null
+++ b/dev-haskell/gtk3/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This is the core library of the Gtk2Hs suite of libraries for Haskell
+ based on Gtk+. Gtk+ is an extensive and mature multi-platform toolkit
+ for creating graphical user interfaces.
+ </longdescription>
+ <use>
+ <flag name="gio">Depend on GIO package, thereby enabling certain features.</flag>
+ <flag name="fmode-binary">Set the default file translation mode for file I/O operations to _O_BINARY.</flag>
+ </use>
+</pkgmetadata>