summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 12:56:20 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 12:56:20 +0000
commit9f0d2f2a68bff39651cd098ef809c81caa4bd589 (patch)
tree27b5e68f2c3eb7a218dc07462164554a9e142273 /dev-haskell
parentBump opengl to 2.6.0.1 (diff)
downloadgentoo-2-9f0d2f2a68bff39651cd098ef809c81caa4bd589.tar.gz
gentoo-2-9f0d2f2a68bff39651cd098ef809c81caa4bd589.tar.bz2
gentoo-2-9f0d2f2a68bff39651cd098ef809c81caa4bd589.zip
Add async
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/async/ChangeLog9
-rw-r--r--dev-haskell/async/Manifest3
-rw-r--r--dev-haskell/async/async-2.0.1.4.ebuild29
-rw-r--r--dev-haskell/async/metadata.xml51
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-haskell/async/ChangeLog b/dev-haskell/async/ChangeLog
new file mode 100644
index 000000000000..2cb9a8107d05
--- /dev/null
+++ b/dev-haskell/async/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/async
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/async/ChangeLog,v 1.1 2012/11/18 12:56:20 gienah Exp $
+
+*async-2.0.1.4 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org> +async-2.0.1.4.ebuild,
+ +metadata.xml:
+ Add async
diff --git a/dev-haskell/async/Manifest b/dev-haskell/async/Manifest
new file mode 100644
index 000000000000..76630a35919f
--- /dev/null
+++ b/dev-haskell/async/Manifest
@@ -0,0 +1,3 @@
+DIST async-2.0.1.4.tar.gz 8349 SHA256 41ddfe012d98f3ef101651fb529753bca5bb4c804f03f9cfafc5d0cbe50224c2 SHA512 8b170644ce92f9788e22771239542e46ee14b9898404744f6a97b955ef22ae4b3fa280ea759f228cb22f2083b5ee007f39c61063f82e5cce8f6bf1c6df789a71 WHIRLPOOL 3f95800777b3efb160b1bbe4356d9fa2a76b7bc0e6143fce8823b062854a42c465ab2d84c2c695592ef78a9cc831428807342b2c7a86d2e0ff0750bccf53b622
+EBUILD async-2.0.1.4.ebuild 754 SHA256 f24e452e17a68b06dc0e53e19bdbb0891d9a1f0b2cb55c5e6c0ad1c9289578cb SHA512 dd245b7737659d786bdcfcd3957c33ec954863ae548c35016faf99daaded6a73bad2ff4d509c20867fb28b7680520e43c65bc30133ef1ded77c637028adfd52f WHIRLPOOL 66d72d08f2db06c6fe9fcd349c997a3b3cc17840b7d610a2fe7ac3b96a1087c09b350ffcaf1d5aec5ff762a54977c43f1a24a9f52bdd24809d456046c1783296
+MISC metadata.xml 1543 SHA256 5102acddf23680f51ce6de4abbf74677adc45b6a70ab6106d4043db8fd0e0516 SHA512 cf24798395d4aecdc64a5e1619ac5d99ca963b90d22e508c1232731dc6d860288ecca2cda9676ab8a8338efbfebe91898b39fe70b9adf6e7b0abf645b0dc14f9 WHIRLPOOL 2a223c23ff46d0a70c19afd02a25b7ed21ae5c4842bf72b6709cde52a453a679ac0c99a5e81c79e451bc6d740f8b294284913b44897d69c1c1f19769d77feebd
diff --git a/dev-haskell/async/async-2.0.1.4.ebuild b/dev-haskell/async/async-2.0.1.4.ebuild
new file mode 100644
index 000000000000..ad6aa2470895
--- /dev/null
+++ b/dev-haskell/async/async-2.0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/async/async-2.0.1.4.ebuild,v 1.1 2012/11/18 12:56:20 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?]
+ <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ )
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/async/metadata.xml b/dev-haskell/async/metadata.xml
new file mode 100644
index 000000000000..84cdf135d3f5
--- /dev/null
+++ b/dev-haskell/async/metadata.xml
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a higher-level interface over
+ threads, in which an @Async a@ is a concurrent
+ thread that will eventually deliver a value of
+ type @a@. The package provides ways to create
+ @Async@ computations, wait for their results, and
+ cancel them.
+
+ Using @Async@ is safer than using threads in two
+ ways:
+
+ * When waiting for a thread to return a result,
+ if the thread dies with an exception then the
+ caller must either re-throw the exception
+ (&#39;wait&#39;) or handle it (&#39;waitCatch&#39;); the
+ exception cannot be ignored.
+
+ * The API makes it possible to build a tree of
+ threads that are automatically killed when
+ their parent dies (see &#39;withAsync&#39;).
+
+ Changes in 2.0.1.3:
+
+ * Bump @base@ dependency to allow 4.6
+
+ Changes in 2.0.1.2:
+
+ * Bump @stm@ dependency to 2.4
+
+ Changes in 2.0.1.1:
+
+ * Safe Haskell support: @Control.Concurrent.Async@ is now @Trustworthy@
+
+ Changes in 2.0.1.0:
+
+ * Added a @Functor@ instance for @Async@
+
+ * Added @asyncBound@, @asyncOn@, @asyncWithUnmask@, @asyncOnWithUnmask@, @withAsyncBound@, @withAsyncOn@, @withAsyncWithUnmask@, @withAsyncOnWithUnmask@.
+
+ * Added @mapConcurrently@
+
+ * Added @Concurrently@ (with @Applicative@ and @Alternative@ instances)
+ </longdescription>
+</pkgmetadata>