summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 10:26:03 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 10:26:03 +0000
commitb4f072e3adb8ee948b7d2714b842ccc76edc5157 (patch)
treeea1aa64e8330c2621026525ecbc953488e1b06d4 /dev-haskell
parentUpdate permission fixing code. Per bug #266432. (diff)
downloadgentoo-2-b4f072e3adb8ee948b7d2714b842ccc76edc5157.tar.gz
gentoo-2-b4f072e3adb8ee948b7d2714b842ccc76edc5157.tar.bz2
gentoo-2-b4f072e3adb8ee948b7d2714b842ccc76edc5157.zip
Version bump dev-haskell/quickcheck
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/quickcheck/ChangeLog10
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild24
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index 3446592eefbb..118b23e637f7 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/quickcheck
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.31 2008/10/04 17:55:19 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.32 2009/04/19 10:26:03 kolmodin Exp $
+
+*quickcheck-1.2.0.0 (19 Apr 2009)
+
+ 19 Apr 2009; Lennart Kolmodin <kolmodin@gentoo.org>
+ +quickcheck-1.2.0.0.ebuild:
+ Version bump.
04 Oct 2008; Raúl Porcel <armin76@gentoo.org> quickcheck-1.1.0.0.ebuild:
alpha/ia64 stable
diff --git a/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild b/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
new file mode 100644
index 000000000000..fa0cec764904
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild,v 1.1 2009/04/19 10:26:03 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://www.math.chalmers.se/~rjmh/QuickCheck/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"