summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 09:55:56 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 09:55:56 +0000
commitb51e3087149fd12524fd4b23d300c88bfbfb88b4 (patch)
tree71fa4c9a118b78222c084b9a9b67f9605cd4b682 /dev-haskell
parentAdd libxml for test-framework (diff)
downloadgentoo-2-b51e3087149fd12524fd4b23d300c88bfbfb88b4.tar.gz
gentoo-2-b51e3087149fd12524fd4b23d300c88bfbfb88b4.tar.bz2
gentoo-2-b51e3087149fd12524fd4b23d300c88bfbfb88b4.zip
Bump test-framework to 0.8.0.3
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/test-framework/ChangeLog7
-rw-r--r--dev-haskell/test-framework/test-framework-0.8.0.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-haskell/test-framework/ChangeLog b/dev-haskell/test-framework/ChangeLog
index 8e5748014b08..dfb18a8e1d7f 100644
--- a/dev-haskell/test-framework/ChangeLog
+++ b/dev-haskell/test-framework/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/test-framework
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework/ChangeLog,v 1.29 2013/08/03 07:30:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework/ChangeLog,v 1.30 2013/10/19 09:55:56 gienah Exp $
+
+*test-framework-0.8.0.3 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +test-framework-0.8.0.3.ebuild:
+ Bump test-framework to 0.8.0.3
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> test-framework-0.8.ebuild:
Stable for sparc, wrt bug #472802
diff --git a/dev-haskell/test-framework/test-framework-0.8.0.3.ebuild b/dev-haskell/test-framework/test-framework-0.8.0.3.ebuild
new file mode 100644
index 000000000000..79c78668940d
--- /dev/null
+++ b/dev-haskell/test-framework/test-framework-0.8.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework/test-framework-0.8.0.3.ebuild,v 1.1 2013/10/19 09:55:56 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Framework for running and organising tests, with HUnit and QuickCheck support"
+HOMEPAGE="https://batterseapower.github.io/test-framework/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+RESTRICT="test" # tests are missing
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.5.1:=[profile?]
+ >=dev-haskell/hostname-1.0:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ >=dev-haskell/regex-posix-0.72:=[profile?]
+ >=dev-haskell/xml-1.3.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/hunit-1.2:=[profile?]
+ >=dev-haskell/libxml-0.1.1:=[profile?]
+ >=dev-haskell/quickcheck-2.3:=[profile?] <dev-haskell/quickcheck-2.7:=[profile?] )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >= 2.3 && < 2.5' 'QuickCheck >= 2.3 && < 2.7'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test tests)
+}